Spine = not so good!

Addons for Cacti and discussion about those addons

Moderators: Moderators, Developers

Post Reply
Author
Message
User avatar
camerabob
Cacti User
Posts: 291
Joined: Fri Feb 10, 2017 2:45 pm
Location: Long Island, New York, USA
Contact:

Spine = not so good!

#1 Post by camerabob » Thu Mar 21, 2019 11:11 am

Before adding Spine:

Code: Select all

2019/03/21 11:07:06 - CMDPHP WARNING: cmd.php poller over ran its polling intervale and therefore ending
2019/03/21 11:07:05 - CMDPHP WARNING: cmd.php poller over ran its polling intervale and therefore ending
2019/03/21 11:07:05 - CMDPHP WARNING: cmd.php poller over ran its polling intervale and therefore ending
2019/03/21 11:07:04 - CMDPHP WARNING: cmd.php poller over ran its polling intervale and therefore ending
2019/03/21 11:07:03 - POLLER: Poller[Main Poller] WARNING: There are '4' detected as overrunning a polling cycle, please investigate
2019/03/21 11:07:00 - SYSTEM STATS: Time:58.6003 Method:cmd.php Processes:8 Threads:N/A Hosts:88 HostsPerProcess:11 DataSources:327 RRDsProcessed:247
2019/03/21 11:07:00 - POLLER: Poller[Main Poller] Maximum runtime of 58 seconds exceeded. Exiting.
After adding Spine:

Code: Select all

2019/03/21 12:02:22 - SYSTEM STATS: Time:19.7314 Method:spine Processes:5 Threads:5 Hosts:88 HostsPerProcess:18 DataSources:284 RRDsProcessed:246
From CentOS, I simply ran

Code: Select all

#yum install cacti-spine
From that point, I had issues with ICMP PINGs, so I then ran the following

Code: Select all

# which spine
/bin/spine
# cd /bin
# chown root.root spine
# chmod -s spine
# chmod u+s spine
After this and some errors for a couple of polling cycles, (I had to return devices since polling occurred MUCH faster) things ran beautifully. If you're not already using Spine, I would recommend it.

***** FOLLOW UP: After some time, I noticed that none of my graphs are being updated. Have spent the past two hours trying to figure out why. Details to follow, or going back to slow, safe cmd.php. The logs doesn't show that anything is wrong.
See the Cacti 1.x templates I use at: http://www.camerabob.com/cacti

Live: Cacti 1.2.3 @ CentOS 7-6.1810.2.el7 & PHP 5.4.16-46.el7
Flowview @ 2.1
Mactrack @ 4.2
Maint @ 1.2
Monitor @ 2.3.6
Thold @ 1.2.4

Test: Cacti 1.2.6-1.el7 @ CentOS 7-7.1908.0.el7 & PHP 5.4.16-46.el7
Maint @ 1.2
Monitor @ 2.3.6
Thold @ 1.2.4

netniV
Cacti Guru User
Posts: 2884
Joined: Sun Aug 27, 2017 12:05 am

Re: Spine = not so good!

#2 Post by netniV » Thu Mar 21, 2019 2:19 pm

You can run spine with the -V 5 option to see what's going on.

Post Reply