WMI for 1.2.3

Addons for Cacti and discussion about those addons

Moderators: Moderators, Developers

Post Reply
Author
Message
ncariaga
Posts: 7
Joined: Fri Jun 27, 2008 8:38 pm
Contact:

WMI for 1.2.3

#1 Post by ncariaga » Tue May 21, 2019 4:25 pm

Been trying to install WMI for Cacti ver 1.2.3 but I'm having problems in doing so. When I copied file files into the ..plugins directory, I accidentally copied to WMI folder instead of WMIC. Because of this I got this error:

2019/05/22 04:23:52 - CMDPHP PHP ERROR WARNING Backtrace: (/plugins.php[74]:api_plugin_install(), /lib/plugins.php[590]:include_once(), /lib/plugins.php[590]:CactiErrorHandler())
2019/05/22 04:23:52 - ERROR PHP WARNING: include_once(): Failed opening '/var/www/html/plugins/wmic/setup.php' for inclusion (include_path='.:/usr/share/php') in file: /var/www/html/lib/plugins.php on line: 590
2019/05/22 04:23:52 - CMDPHP PHP ERROR WARNING Backtrace: (/plugins.php[74]:api_plugin_install(), /lib/plugins.php[590]:include_once(), /lib/plugins.php[590]:CactiErrorHandler())
2019/05/22 04:23:52 - ERROR PHP WARNING: include_once(/var/www/html/plugins/wmic/setup.php): failed to open stream: No such file or directory in file: /var/www/html/lib/plugins.php on line: 590

But when I updated the directory from WMI to WMIC, nothing happens into the portal and no logs are written for the server. please help. thank you.

ncariaga
Posts: 7
Joined: Fri Jun 27, 2008 8:38 pm
Contact:

Re: WMI for 1.2.3

#2 Post by ncariaga » Wed May 22, 2019 11:32 am

ncariaga wrote:Been trying to install WMI for Cacti ver 1.2.3 but I'm having problems in doing so. When I copied file files into the ..plugins directory, I accidentally copied to WMI folder instead of WMIC. Because of this I got this error:

2019/05/22 04:23:52 - CMDPHP PHP ERROR WARNING Backtrace: (/plugins.php[74]:api_plugin_install(), /lib/plugins.php[590]:include_once(), /lib/plugins.php[590]:CactiErrorHandler())
2019/05/22 04:23:52 - ERROR PHP WARNING: include_once(): Failed opening '/var/www/html/plugins/wmic/setup.php' for inclusion (include_path='.:/usr/share/php') in file: /var/www/html/lib/plugins.php on line: 590
2019/05/22 04:23:52 - CMDPHP PHP ERROR WARNING Backtrace: (/plugins.php[74]:api_plugin_install(), /lib/plugins.php[590]:include_once(), /lib/plugins.php[590]:CactiErrorHandler())
2019/05/22 04:23:52 - ERROR PHP WARNING: include_once(/var/www/html/plugins/wmic/setup.php): failed to open stream: No such file or directory in file: /var/www/html/lib/plugins.php on line: 590

But when I updated the directory from WMI to WMIC, nothing happens into the portal and no logs are written for the server. please help. thank you.
I was able to go about the error above by changing the package info from WMIC to WMI. However, when tried installing the file, I notice this error prompting
Capture.JPG
Capture.JPG (21.37 KiB) Viewed 628 times
I hope someone could help out on this. Thank you very much in advance.

ncariaga
Posts: 7
Joined: Fri Jun 27, 2008 8:38 pm
Contact:

Re: WMI for 1.2.3

#3 Post by ncariaga » Wed May 22, 2019 1:32 pm

After viewing the log files, I found these log entries. I was hoping someone could help me figure out what went wrong:

2019/05/23 02:21:40 - CMDPHP SQL Backtrace: (/plugins.php[74]:api_plugin_install(), /lib/plugins.php[626]:plugin_wmi_install(), /plugins/wmi/setup.php[41]:plugin_wmi_setup_tables(), /plugins/wmi/setup.php[186]:sql_save())
2019/05/23 02:21:40 - DBCALL ERROR: SQL Save on table 'Array': Table does not exist, unable to save!
2019/05/23 02:21:40 - CMDPHP PHP ERROR NOTICE Backtrace: (/plugins.php[74]:api_plugin_install(), /lib/plugins.php[626]:plugin_wmi_install(), /plugins/wmi/setup.php[41]:plugin_wmi_setup_tables(), /plugins/wmi/setup.php[186]:sql_save(), /lib/database.php[1342]:CactiErrorHandler())
2019/05/23 02:21:40 - ERROR PHP NOTICE: Array to string conversion in file: /var/www/html/lib/database.php on line: 1342
2019/05/23 02:21:40 - CMDPHP PHP ERROR WARNING Backtrace: (/plugins.php[74]:api_plugin_install(), /lib/plugins.php[626]:plugin_wmi_install(), /plugins/wmi/setup.php[41]:plugin_wmi_setup_tables(), /plugins/wmi/setup.php[186]:sql_save(), /lib/database.php[1341]:db_table_exists(), /lib/database.php[730]:array_key_exists(), CactiErrorHandler())
2019/05/23 02:21:40 - ERROR PHP WARNING: array_key_exists() expects parameter 2 to be array, null given in file: /var/www/html/lib/database.php on line: 730
2019/05/23 02:21:40 - CMDPHP PHP ERROR WARNING Backtrace: (/plugins.php[74]:api_plugin_install(), /lib/plugins.php[626]:plugin_wmi_install(), /plugins/wmi/setup.php[41]:plugin_wmi_setup_tables(), /plugins/wmi/setup.php[186]:sql_save(), /lib/database.php[1341]:db_table_exists(), /lib/database.php[729]:preg_match(), CactiErrorHandler())
2019/05/23 02:21:40 - ERROR PHP WARNING: preg_match() expects parameter 2 to be string, array given in file: /var/www/html/lib/database.php on line: 729
2019/05/23 02:21:40 - CMDPHP SQL Backtrace: (/plugins.php[74]:api_plugin_install(), /lib/plugins.php[626]:plugin_wmi_install(), /plugins/wmi/setup.php[41]:plugin_wmi_setup_tables(), /plugins/wmi/setup.php[179]:db_fetch_cell(), /lib/database.php[358]:db_fetch_cell_prepared(), /lib/database.php[374]:db_execute_prepared())
2019/05/23 02:21:40 - CMDPHP ERROR: A DB Cell Failed!, Error: Unknown column 'id' in 'field list'

netniV
Cacti Guru User
Posts: 2881
Joined: Sun Aug 27, 2017 12:05 am

Re: WMI for 1.2.3

#4 Post by netniV » Fri Jun 07, 2019 3:04 pm

I believe that you submitted this as a change on the repo and it has now been committed.

Post Reply