cacti Migration

If you figure out how to do something interesting/cool in Cacti and want to share it with the community, please post your experience here.

Moderators: Moderators, Developers

Post Reply
Author
Message
coolcliff
Posts: 14
Joined: Wed Dec 20, 2017 3:51 am

cacti Migration

#1 Post by coolcliff » Mon Mar 18, 2019 3:50 am

Hi All

i have cacti 1.1.38 installed and working for almost a year, however the server does not create the 95th percentile graphs, the server show that the graph was created successfully, but all i see is an error " Unknown RRDtool error"

so i decided to upgrade to 1.2.2, here the 95th percentile graphs are working fine, however i had done the installation under the directory /opt/cacti-1.1.38/

and the 1.2.2 install is under /usr/share/cacti

i have tried importing and upgrading the database however i get the log errors for bot cacti and weathermap like the below
/opt/cacti-1.1.38/rra/58/1735.rrd had no valid data etc

i need to know where the changes to the directory structures need to be done so the system is upgraded successfully, and one more thing the 95th percentile graphs stop working after i import the database from the old system

please guide me how to get around the above issues

Regards
Clifford Dsouza

netniV
Cacti Guru User
Posts: 2656
Joined: Sun Aug 27, 2017 12:05 am

Re: cacti Migration

#2 Post by netniV » Mon Mar 18, 2019 5:02 am

Sounds to me like you either have a symlink under your cacti folder, or you are still trying to run the 1.1.38 poller in your cron

coolcliff
Posts: 14
Joined: Wed Dec 20, 2017 3:51 am

Re: cacti Migration

#3 Post by coolcliff » Mon Mar 18, 2019 6:10 am

The new install was done via the yum install method, ive checked my cron in the new system, its running the new poller

Regards

Clifford

netniV
Cacti Guru User
Posts: 2656
Joined: Sun Aug 27, 2017 12:05 am

Re: cacti Migration

#4 Post by netniV » Mon Mar 18, 2019 11:36 am

Cacti uses the RRA folder underneath itself. So, unless something has redirected that to another location, it would be under its own website root. Wherever the RRD's are actually stored must have read/write permissions for both the user used by the website and the user used by the poller.

You can use the Troubleshoot -> Data Sources option to actually verify these things in 1.2

coolcliff
Posts: 14
Joined: Wed Dec 20, 2017 3:51 am

Re: cacti Migration

#5 Post by coolcliff » Tue Mar 19, 2019 12:25 am

Hi

Not working for me.. tried everything, is it possible to export just the devices and the graphs from the old system and import it into the new system

Like i said the old cacti directory installation is /opt/cacti-1.1.38/
The new install was done with a yum install so it defaults to /usr/share/cacti folder (Cacti version is 1.2.2)

is migration possible in this scenario?

cause when i imported the db from the old cacti system, the new working cacti system stopped graphing and even the 95th percentile graphs did not work with the "Unknown RRDtool error" message.

the reaon for upgrade from cacti 1.1.38 was that the 95th percentile graphs were not working

Regards
Clifford Dsouza

Post Reply