Autom8 for devices w/o DNS entry - multiple community

Anything that you think should be in Cacti.

Moderators: Moderators, Developers

Post Reply
Author
Message
choefing
Posts: 20
Joined: Tue May 04, 2010 4:47 am

Autom8 for devices w/o DNS entry - multiple community

#1 Post by choefing » Mon Mar 13, 2017 9:11 am

Hi Gents,

we monitor a lot of devices that don't have DNS entries, several hundreds which unfortunately change often in some of the networks, so a manual "host" file or dummy-dns would bring autom8 ad absurdum for us.
Not quite sure if its just missed out on purpose or maybe not working as desired, so I'll post that here as feature request before bug.

In the list of discovered devices it only shows "SNMP DOWN - Status up". All devices will show up as e.g. 11.22.33.44.in-addr.arpa and it seems they don't get snmp queried if no DNS is available.
Checked with a ip --> name match in /etc/hosts will immediately show the values retrieved by snmp and "SNMP UP - STATUS UP". So it seems the check autom8 does is related to some kind of a name resolve.

Nevertheless, whenever I set the snmp community to a correct value and add the discovered devices, it will automatically set the hostname to the hostname retrieved via SNMP which is quite what we want.

If I add another snmp community for another kind of devices / another network, then when adding the device will always get the last snmp community string in the list.
So devices with "community1" will fail to be added properly with name, while devices with "community2" would be added correctly using snmp retrieved host name.

Thanks.


w/o resolvable name - 0 Responded to SNMP

Code: Select all

 2017-03-13 14:12:53 - AUTOM8 Network CMMN Thread 3 Finished, 1 IPs Scanned, 1 IPs Responded to Ping, 0 Responded to SNMP, 0 Device Added, 0 Graphs Added to Cacti 
2017-03-13 14:12:53 - CMDPHP PHP ERROR WARNING Backtrace: (/poller_automation.php: 318 discoverDevices)(/poller_automation.php: 467 automation_valid_snmp_device)(/lib/api_automation.php: 3051 cacti_snmp_session)(/lib/snmp.php: 52 __construct)(CactiErrorHandler)(/lib/functions.php: 4260 cacti_debug_backtrace)
2017-03-13 14:12:53 - ERROR PHP WARNING: SNMP::__construct(): php_network_getaddresses: getaddrinfo failed: No address associated with hostname in file: /var/www/html/cacti/lib/snmp.php on line: 52 
w/ resovleable name (in /etc/host) - 1 IPs Responded to Ping

Code: Select all

 2017-03-13 14:18:09 - AUTOM8 Network CMMN Thread 1 Finished, 1 IPs Scanned, 1 IPs Responded to Ping, 1 Responded to SNMP, 0 Device Added, 0 Graphs Added to Cacti 

User avatar
Osiris
Cacti Pro User
Posts: 863
Joined: Mon Jan 05, 2015 10:10 am

Re: Autom8 for devices w/o DNS entry - multiple community

#2 Post by Osiris » Mon Mar 13, 2017 8:11 pm

Please log an issue in Github and provide the same level of detail you did here. If this is NOT Cacti 1.0.x, then don't bother. They are not supporting the old stuff.
Before history, there was a paradise, now dust.


User avatar
Osiris
Cacti Pro User
Posts: 863
Joined: Mon Jan 05, 2015 10:10 am

Re: Autom8 for devices w/o DNS entry - multiple community

#4 Post by Osiris » Tue Mar 21, 2017 7:02 am

Looks like it was resolved in 1.1.0.
Before history, there was a paradise, now dust.

Post Reply