Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Sun Jul 21, 2019 2:15 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 13 posts ] 
Author Message
 Post subject: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool graph"
PostPosted: Thu Aug 08, 2013 2:15 am 
Offline

Joined: Thu Aug 08, 2013 2:12 am
Posts: 2
Hi,

after upgrading to 0.8.8b we have problems with some thumbnail graphs.
In the logfile we found:

/usr/bin/rrdtool graph - --imgformat=PNG --start=1375857758
--end=1375944158 --title='spruce.ham.foo.bar - Errors - Gi1/0/2
Out-of-band-Mgmt via [email protected]' --rigid --base=1000 --height=100
--width=300 --alt-autoscale-max --lower-limit='0' --no-legend
COMMENT:"From 2013/08/07 08\:42\:38 To 2013/08/08 08\:42\:38\c"
--vertical-label='errors/sec' --slope-mode --font TITLE:7: --font
AXIS:7: --font LEGEND:8: --font UNIT:7:
DEF:a='/var/www/cacti/rra/2/3623.rrd':'discards_in':AVERAGE
DEF:b='/var/www/cacti/rra/2/3623.rrd':'errors_in':AVERAGE
DEF:c='/var/www/cacti/rra/2/3623.rrd':'discards_out':AVERAGE
DEF:d='/var/www/cacti/rra/2/3623.rrd':'errors_out':AVERAGE
CDEF:cdefbh='a,UN,INF,UNKN,IF' LINE1:a#FFAB00FF:''
LINE1:b#F51D30FF:'' LINE1:c#C4FD3DFF:'' LINE1:d#00694AFF:''
COMMENT:'' AREA:cdefbh#8F9286FF:''

This results in "ERROR: Expected some arguments after 'COMMENT:'" and no
thumbnail displayed.

rrdtool -V
RRDtool 1.3.8 Copyright 1997-2009 by Tobias Oetiker <[email protected]>
Compiled Feb 23 2010 21:36:53


Why are there three COMMENT-arguments in this command?? The thoird one (empty COMMENT) results in the error.

How can we fix it?


Cheers
Christian


Top
 Profile  
 
 Post subject: Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra
PostPosted: Thu Aug 08, 2013 6:51 am 
Offline

Joined: Thu Aug 08, 2013 2:12 am
Posts: 2
Result from mailing-list:

It's a bug, Gandalf provide a patch for testing and I hope the final patch will be released soon.

If you are hurry: please look at the mailinglist at the moment :-)

Cheers
Christian


Top
 Profile  
 
 Post subject: Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra
PostPosted: Fri Aug 09, 2013 2:45 pm 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22376
Location: Muenster, Germany
This has been reported to the mantis bug tracker as well. The patch is available there and I will attach it here.
We are planning to publish a fixed version, soon (for those who do not like to use the "patch" command)

R.


Attachments:
cacti088b_empty_comment.patch [2.56 KiB]
Downloaded 2311 times

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository
Top
 Profile  
 
 Post subject: Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra
PostPosted: Wed Sep 18, 2013 7:51 pm 
Offline

Joined: Mon Jul 22, 2013 1:23 pm
Posts: 11
how do I run the patch? new to centOS


Top
 Profile  
 
 Post subject: Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra
PostPosted: Wed Sep 18, 2013 8:19 pm 
Offline

Joined: Mon Jul 22, 2013 1:23 pm
Posts: 11
I ran the patch and rebooted still no luck, what else do I need to do?


Top
 Profile  
 
 Post subject: Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra
PostPosted: Thu Sep 19, 2013 2:54 pm 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22376
Location: Muenster, Germany
Please post the whole rrdtool statement from Graph Management in debug mode
R.

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject: Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra
PostPosted: Thu Sep 19, 2013 7:58 pm 
Offline

Joined: Mon Jul 22, 2013 1:23 pm
Posts: 11
crap how do I do that?


Top
 Profile  
 
 Post subject: Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra
PostPosted: Thu Sep 19, 2013 8:00 pm 
Offline

Joined: Mon Jul 22, 2013 1:23 pm
Posts: 11
im really trying to learn this

RRDTool Command:

Notice: Undefined offset: 1 in /var/www/html/plugins/thold/setup.php on line 217

Notice: Undefined offset: 1 in /var/www/html/plugins/thold/setup.php on line 218
/usr/bin/rrdtool graph - \
--imgformat=PNG \
--start=-86400 \
--end=-60 \
--title='ASA CW 290 - CPU Usage' \
--rigid \
--base=1000 \
--height=120 \
--width=500 \
--alt-autoscale-max \
--lower-limit='0' \
--vertical-label='percent' \
--slope-mode \
--font TITLE:10: \
--font AXIS:8: \
--font LEGEND:8: \
--font UNIT:8: \
DEF:a='/var/www/html/rra/asa_cw_290_5min_cpu_503.rrd':'5min_cpu':AVERAGE \
--watermark "Created using CactiEZ" \
AREA:a#FF0000FF:'CPU Usage' \
GPRINT:a:LAST:'Current\:%8.0lf' \
GPRINT:a:AVERAGE:'Average\:%8.0lf' \
GPRINT:a:MAX:'Maximum\:%8.0lf\n' \
COMMENT:' \n' \
COMMENT:'Last Updated \: Thu 19 Sep 20\:00\:39 MDT 2013' RRDTool Says:

Notice: Undefined offset: 1 in /var/www/html/plugins/thold/setup.php on line 217

Notice: Undefined offset: 1 in /var/www/html/plugins/thold/setup.php on line 218
OK


Top
 Profile  
 
 Post subject: Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra
PostPosted: Sat Sep 21, 2013 2:16 am 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22376
Location: Muenster, Germany
This rrdtool statement does not show any error (apart from the issues caused by the thold plugin). How does the graph look like?
R.

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject: Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra
PostPosted: Sat Sep 21, 2013 4:36 pm 
Offline

Joined: Sun Sep 08, 2013 8:30 am
Posts: 4
I got the same error in graph D & F after I installed the ApacheStats_0.8.2 template. I tried the patch in cacti directory but I've got the following error message.

patch -p1 -N < cacti088b_empty_comment.patch
==========================================================================
can't find file to patch at input line 7
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|### Eclipse Workspace Patch 1.0
|#P cacti088
|Index: lib/rrd.php
|===================================================================
|--- lib/rrd.php (Revision 7407)
|+++ lib/rrd.php (Arbeitskopie)
--------------------------
File to patch:
Skip this patch? [y]
Skipping patch.
1 out of 1 hunk ignored
==========================================================================

RRDTool debug message
==========================================================================
RRDTool Command:

/usr/bin/rrdtool graph - \
--imgformat=PNG \
--start=-86400 \
--end=-300 \
--title='Localhost - Apache Stats - D - Bytes / Hit' \
--base=1024 \
--height=120 \
--width=500 \
--alt-autoscale-max \
--lower-limit='0' \
--vertical-label='bytes per hit' \
--slope-mode \
--font TITLE:10: \
--font AXIS:7: \
--font LEGEND:8: \
--font UNIT:7: \
DEF:a='/var/www/cacti-0.8.8b/rra/localhost_apache_total_kbytes_566.rrd':'apache_total_kbytes':AVERAGE \
DEF:b='/var/www/cacti-0.8.8b/rra/localhost_apache_total_hits_565.rrd':'apache_total_hits':AVERAGE \
CDEF:cdefa='a,UN,0,a,100000,GT,0,a,IF,IF' \
CDEF:cdefc='b,UN,0,b,100000,GT,0,b,IF,IF' \
CDEF:cdefe='cdefc,0,EQ,0,cdefa,1024,*,cdefc,/,IF,0,1000000,LIMIT' \
CDEF:cdefi='a,0,0,LIMIT' \
CDEF:cdefbc='b,0,0,LIMIT' \
COMMENT:'' \
COMMENT:'' \
COMMENT:'' \
COMMENT:'' \
AREA:cdefe#4123A1FF:'Bytes / Hit' \
GPRINT:cdefe:LAST:'Current\:%8.2lf %s' \
GPRINT:cdefe:AVERAGE:'Average\:%8.2lf %s' \
GPRINT:cdefe:MAX:'Maximum\:%8.2lf %s\n' \
LINE2:cdefi#FF0000FF:'kBytes' \
GPRINT:a:LAST:' Current\:%8.2lf %s' \
GPRINT:a:AVERAGE:'Average\:%8.2lf %s' \
GPRINT:a:MAX:'Maximum\:%8.2lf %s\n' \
LINE2:cdefbc#00FF00FF:'Hits' \
GPRINT:b:LAST:' Current\:%8.2lf %s' \
GPRINT:b:AVERAGE:'Average\:%8.2lf %s' \
GPRINT:b:MAX:'Maximum\:%8.2lf %s\n'

RRDTool Says:

ERROR: Expected some arguments after 'COMMENT:'


Top
 Profile  
 
 Post subject: Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra
PostPosted: Sun Sep 22, 2013 10:19 am 
Offline
Cacti Pro User

Joined: Tue Aug 29, 2006 4:09 pm
Posts: 590
Location: NL
atpt wrote:
I got the same error in graph D & F after I installed the ApacheStats_0.8.2 template. I tried the patch in cacti directory but I've got the following error message.

patch -p1 -N < cacti088b_empty_comment.patch
==========================================================================
can't find file to patch at input line 7

So in which directory were you standing while applying this patch? Your -p level was wrong, or you were completely in the wrong location. Until you applied the patch correctly, don't expect this issue to resolve itself.

_________________
Maintainer of cacti in Debian (and Ubuntu).
Cacti 1.* is now officially supported on Debian Stretch via Debian backports
FAQ Ubuntu and Debian differences
Generic cacti debugging


Top
 Profile  
 
 Post subject: Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra
PostPosted: Sun Sep 22, 2013 1:18 pm 
Offline

Joined: Sun Sep 08, 2013 8:30 am
Posts: 4
paulgevers wrote:
atpt wrote:
I got the same error in graph D & F after I installed the ApacheStats_0.8.2 template. I tried the patch in cacti directory but I've got the following error message.

patch -p1 -N < cacti088b_empty_comment.patch
==========================================================================
can't find file to patch at input line 7

So in which directory were you standing while applying this patch? Your -p level was wrong, or you were completely in the wrong location. Until you applied the patch correctly, don't expect this issue to resolve itself.


Thanks for your remind. I messed up my testing environment before. The patch can be apply without problem.


Top
 Profile  
 
 Post subject: Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra
PostPosted: Sat Mar 08, 2014 3:56 pm 
Offline

Joined: Sun Aug 25, 2013 2:10 am
Posts: 4
To fix the no thumbnail graphs showing when checking the thumbnail box.

THANK YOU to user sdavied for posting a patch file in another post. What some people may be missing that are relatively "novice" users of Cacti is how "exactly" to apply it.

If you installed the EZCacti use the Cacti WebAdmin at http://<ipaddress>:10000 in a web browser and go to the "Upload and download" topic on the left colum. Here is where you upload the patch to your server that user sdavied uploaded earlier. Upload the patch file to the directory /var/www/html Remember this does not apply the patch, it only sends it to the server.

You can use the SSH tool in the WebAdmin that you just used, but I find it easier to go the terminal of your server either sitting right at it or by ssh. Issue the command cd /var/www/html and hit return. It should return to a prompt with html in it. Then type patch -p0 -b < rrd.php.patch and hit enter. This should return to the same html prompt that you were just at.....with no errors.

That's it. Go back to your Cacti webpage and do a page refresh and click on the "Thumbnails" checkbox and you will see your graphs again for the first time in months !

Just in case I attached sdavied file from a previous post.

Hope this helps a lot of people....it worked for me.

Gary


Attachments:
rrd.php.patch [2.5 KiB]
Downloaded 936 times
Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group