Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Tue Feb 19, 2019 7:53 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 25 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Juniper MX960 host template
PostPosted: Thu May 24, 2012 4:46 am 
Offline
Cacti User
User avatar

Joined: Wed Nov 09, 2005 8:35 am
Posts: 240
Location: Timisoara, Romania
so this is a host template that works for me, for juniper MX960 series, dont know if it will work on your mx960 ...


Attachments:
dropqueue.png
dropqueue.png [ 43.28 KiB | Viewed 17695 times ]
domtemp.png
domtemp.png [ 17.28 KiB | Viewed 17695 times ]
cpufru.png
cpufru.png [ 28.55 KiB | Viewed 17695 times ]
buffer.png
buffer.png [ 18.1 KiB | Viewed 17695 times ]

_________________
Check out my CACTI Templates


Last edited by timi on Thu May 24, 2012 4:50 am, edited 1 time in total.
Top
 Profile  
 
 Post subject: Re: Juniper MX960 host template
PostPosted: Thu May 24, 2012 4:47 am 
Offline
Cacti User
User avatar

Joined: Wed Nov 09, 2005 8:35 am
Posts: 240
Location: Timisoara, Romania
continue


Attachments:
pps.png
pps.png [ 33.07 KiB | Viewed 17694 times ]
kernel.png
kernel.png [ 18.62 KiB | Viewed 17694 times ]
heap.png
heap.png [ 17.84 KiB | Viewed 17694 times ]
errors.png
errors.png [ 31.48 KiB | Viewed 17694 times ]

_________________
Check out my CACTI Templates
Top
 Profile  
 
 Post subject: Re: Juniper MX960 host template
PostPosted: Thu May 24, 2012 4:48 am 
Offline
Cacti User
User avatar

Joined: Wed Nov 09, 2005 8:35 am
Posts: 240
Location: Timisoara, Romania
continue


Attachments:
traffic.png
traffic.png [ 32.79 KiB | Viewed 17694 times ]
tempfru.png
tempfru.png [ 19.03 KiB | Viewed 17694 times ]
rx.png
rx.png [ 53.17 KiB | Viewed 17694 times ]
ppsqueue.png
ppsqueue.png [ 34.64 KiB | Viewed 17694 times ]

_________________
Check out my CACTI Templates
Top
 Profile  
 
 Post subject: Re: Juniper MX960 host template
PostPosted: Thu May 24, 2012 4:50 am 
Offline
Cacti User
User avatar

Joined: Wed Nov 09, 2005 8:35 am
Posts: 240
Location: Timisoara, Romania

the oids for interface statistics are not from IF-MIB, I used specific juniper oid for getting interface statistics

see my sig for downloads

thanks


_________________
Check out my CACTI Templates


Top
 Profile  
 
 Post subject: Re: Juniper MX960 host template
PostPosted: Wed May 30, 2012 6:41 am 
Offline
Cacti User
User avatar

Joined: Wed Nov 09, 2005 8:35 am
Posts: 240
Location: Timisoara, Romania
added traffic graphs for ipv6 interface


Attachments:
ipv6.png
ipv6.png [ 25.22 KiB | Viewed 17642 times ]

_________________
Check out my CACTI Templates
Top
 Profile  
 
 Post subject: Re: Juniper MX960 host template
PostPosted: Fri Nov 30, 2012 4:40 am 
Offline

Joined: Fri Apr 03, 2009 7:42 am
Posts: 10
Hello Timi,

I am trying to graph the ipv6 traffic on a Juniper MX960 ver10.4R7.5 but i cann't (Cacti version 8.8.a). I get the following error:

11/30/2012 11:25:12 AM - SYSTEM STATS: Time:11.1522 Method:cmd.php Processes:1 Threads:N/A Hosts:54 HostsPerProcess:54 DataSources:321 RRDsProcessed:163
11/30/2012 11:25:12 AM - CMDPHP: Poller[0] Host[88] Description[amsmx961] DS[507] Graphs['xe-1/1/1 - * Level_3_Amsterdam_ - bits/s (ipv6)'] WARNING: Result from SNMP not valid. Partial Result: U
11/30/2012 11:25:12 AM - CMDPHP: Poller[0] Host[88] Description[amsmx961] DS[507] Graphs['xe-1/1/1 - * Level_3_Amsterdam_ - bits/s (ipv6)'] WARNING: Result from SNMP not valid. Partial Result: U

The xe interface has ipv4 & ipv6 address (no subinterface).
Do you have any idea?
Thanks for your help.


Top
 Profile  
 
 Post subject: Re: Juniper MX960 host template
PostPosted: Fri Nov 30, 2012 9:18 am 
Offline

Joined: Fri Apr 03, 2009 7:42 am
Posts: 10
After some research the MIB .1.3.6.1.4.1.2636.3.11.1.3 doesn't supported on my Junos release ver10.4R7.5 but after the 11.2.

Anyway, Timi thank you for the templates.


Top
 Profile  
 
 Post subject: Re: Juniper MX960 host template
PostPosted: Mon Dec 03, 2012 3:55 am 
Offline
Cacti User
User avatar

Joined: Wed Nov 09, 2005 8:35 am
Posts: 240
Location: Timisoara, Romania
it is very likely that earlier version of junos dont have that oid

_________________
Check out my CACTI Templates


Top
 Profile  
 
 Post subject: Re: Juniper MX960 host template
PostPosted: Sun Jan 20, 2013 7:30 am 
Offline

Joined: Wed Jan 16, 2013 5:11 am
Posts: 3
PLEASE HELP ME TO HAVE JUNIPER MX960 Total Users ( Active Users or Subscribers ) Cacti Template .

OID :
1.3.6.1.4.1.2636.3.64.1.1.1.1


Top
 Profile  
 
 Post subject: Re: Juniper MX960 host template
PostPosted: Mon Jan 21, 2013 3:32 am 
Offline
Cacti User
User avatar

Joined: Wed Nov 09, 2005 8:35 am
Posts: 240
Location: Timisoara, Romania
you can start by reading http://docs.cacti.net/manual:087:3_templates#templates

_________________
Check out my CACTI Templates


Top
 Profile  
 
 Post subject: Re: Juniper MX960 host template
PostPosted: Tue Mar 19, 2013 10:06 am 
Offline

Joined: Wed Oct 24, 2007 1:08 am
Posts: 41
Location: Yerevan, Armenia
Hi timi,

I am willing to use your templates to graph our devices.
Unfortunately I've faced some problems, couple them i was able to resolve by myself.
Firs of all there was a problem in Your Data templates with naming. All data sources have been generating with same string and I've got lots of Data Sources with exact same name (see the picture).
Iv'e fixed that by changing the name field Data Template.
For example for template "Juniper DOM RX Optical Monitor" I've changed name field to
Code:
|host_description| - RX Power - |query_ifName|

and this gave me more descriptive naming for Data Sources.
Another problem I've faces is related to perl script You wrote.
Particularly when i was trying to graph "Juniper MX960 Interface COS Queue Drop", the verbose query gave me:
Code:
+ Running data query [11].
+ Found type = '4' [Script Query].
+ Found data query XML file at '/opt/cacti-0.8.8a/resource/script_queries/juniper_intcos.xml'
+ XML file parsed ok.
+ <arg_num_indexes> missing in XML file, 'Index Count Changed' emulated by counting arg_index entries
+ Executing script for list of indexes 'perl /opt/cacti-0.8.8a/scripts/junipercos.pl 10.16.16.22 BGP/[email protected] index' Index Count: 0
+ Executing script query 'perl /opt/cacti-0.8.8a/scripts/junipercos.pl 10.16.16.22 BGP/[email protected] query index'
+ Executing script query 'perl /opt/cacti-0.8.8a/scripts/junipercos.pl 10.16.16.22 BGP/[email protected] query desc'
+ Executing script query 'perl /opt/cacti-0.8.8a/scripts/junipercos.pl 10.16.16.22 BGP/[email protected] query ifname'
+ Executing script query 'perl /opt/cacti-0.8.8a/scripts/junipercos.pl 10.16.16.22 BGP/[email protected] query ifalias'
+ Executing script query 'perl /opt/cacti-0.8.8a/scripts/junipercos.pl 10.16.16.22 BGP/[email protected] query iftype'

when I've tried to launch:
Code:
perl /opt/cacti-0.8.8a/scripts/junipercos.pl 10.16.16.22 BGP/[email protected]

manually I've got no output.
As You can see from community "BGP/[email protected]" i am trying to get statistics from juniper's logical-system BGP's default routing instance and i guess symbols "/" and "@" are causing troubles.
Sure enough if i am querying the main instance with community "cactirocommunity" i am getting interfaces just fine.
And finally, just as a suggestion, it will be great to have all these with snmpv3 authentication also.

Please give me a clue with my problems, and thanks for great job!
P.S.
Just for info: I am using Ubuntu 12.04.2 LTS
P.P.S. Let me know if You need anything more.

Thanks in advance.


Attachments:
Screenshot.png
Screenshot.png [ 197.73 KiB | Viewed 16255 times ]

_________________
Best Regards.
Top
 Profile  
 
 Post subject: Re: Juniper MX960 host template
PostPosted: Fri Nov 08, 2013 6:47 pm 
Offline

Joined: Mon Jun 25, 2012 1:24 am
Posts: 9
Dear Timi ;
I try with your template . But It 's only work with Interface Statistic .
Below is debug from Other template : Could you help me with bug ?

+ Running data query [20].
+ Found type = '4' [Script Query].
+ Found data query XML file at '/usr/share/cacti/resource/script_queries/juniper_int_queue.xml'
+ XML file parsed ok.
+ <arg_num_indexes> missing in XML file, 'Index Count Changed' emulated by counting arg_index entries
+ Executing script for list of indexes 'perl /usr/share/cacti/scripts/juniper_int_queue.pl my_ip my_community index' Index Count: 0
+ Executing script query 'perl /usr/share/cacti/scripts/juniper_int_queue.pl my_ip my_community query index'
+ Executing script query 'perl /usr/share/cacti/scripts/juniper_int_queue.pl my_ip my_community query desc'
+ Executing script query 'perl /usr/share/cacti/scripts/juniper_int_queue.pl my_ip my_community query ifname'
+ Executing script query 'perl /usr/share/cacti/scripts/juniper_int_queue.pl my_ip my_community query ifalias'
+ Executing script query 'perl /usr/share/cacti/scripts/juniper_int_queue.pl my_ip my_community query iftype'


Top
 Profile  
 
 Post subject: Re: Juniper MX960 host template
PostPosted: Thu May 08, 2014 2:55 am 
Offline

Joined: Thu May 08, 2014 2:53 am
Posts: 2
Every time i did add temple to my host i get following errors

This data query returned 0 rows, perhaps there was a problem executing this data query. You can run this data query in debug mode to get more information.
Select a graph type:


in Debug query i'm getting this

+ Running data query [12].
+ Found type = '4' [Script Query].
+ Found data query XML file at '/var/www/html/cacti/resource/script_queries/juniper.xml'
+ XML file parsed ok.
+ <arg_num_indexes> missing in XML file, 'Index Count Changed' emulated by counting arg_index entries
+ Executing script for list of indexes 'perl /var/www/html/cacti/scripts/juniper.pl brio.englab.juniper.net public index' Index Count: 0
+ Executing script query 'perl /var/www/html/cacti/scripts/juniper.pl brio.englab.juniper.net public query index'
+ Executing script query 'perl /var/www/html/cacti/scripts/juniper.pl brio.englab.juniper.net public query description'


can you please help me on this.


Last edited by nilsmax on Thu May 08, 2014 3:12 am, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: Juniper MX960 host template
PostPosted: Thu May 08, 2014 3:08 am 
Offline
Cacti User
User avatar

Joined: Wed Nov 09, 2005 8:35 am
Posts: 240
Location: Timisoara, Romania
run the script manualy an see if it returns anything, if not then maybe there is a problema un the router like it has no oid for queue or something like it

_________________
Check out my CACTI Templates


Top
 Profile  
 
 Post subject: Re: Juniper MX960 host template
PostPosted: Tue May 13, 2014 1:30 am 
Offline

Joined: Thu May 08, 2014 2:53 am
Posts: 2
:( So resolved the BER.PM issue and SNMP_Session.pm Issue ( which i copied from MRTG)..


Now following error. what next..

# perl /var/www/html/cacti/scripts/juniper.pl brio.englab.juniper.net public query index
Bareword "context_flag" not allowed while "strict subs" in use at /usr/lib/perl5/5.8.0/SNMP_Session.pm line 101.
BEGIN not safe after errors--compilation aborted at /usr/lib/perl5/5.8.0/SNMP_Session.pm line 490.
Compilation failed in require at /usr/lib/perl5/5.8.0/SNMP_util.pm line 35.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.8.0/SNMP_util.pm line 35.
Compilation failed in require at /var/www/html/cacti/scripts/juniper.pl line 6.
BEGIN failed--compilation aborted at /var/www/html/cacti/scripts/juniper.pl line 6.
[[email protected] ~]#


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 25 posts ]  Go to page 1, 2  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: basamo55, Bing [Bot] and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group