cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool graph"

Post support questions that directly relate to Linux/Unix operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
tkshamburg
Posts: 2
Joined: Thu Aug 08, 2013 2:12 am

cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool graph"

#1 Post by tkshamburg » Thu Aug 08, 2013 2:15 am

Hi,

after upgrading to 0.8.8b we have problems with some thumbnail graphs.
In the logfile we found:

/usr/bin/rrdtool graph - --imgformat=PNG --start=1375857758
--end=1375944158 --title='spruce.ham.foo.bar - Errors - Gi1/0/2
Out-of-band-Mgmt via [email protected]' --rigid --base=1000 --height=100
--width=300 --alt-autoscale-max --lower-limit='0' --no-legend
COMMENT:"From 2013/08/07 08\:42\:38 To 2013/08/08 08\:42\:38\c"
--vertical-label='errors/sec' --slope-mode --font TITLE:7: --font
AXIS:7: --font LEGEND:8: --font UNIT:7:
DEF:a='/var/www/cacti/rra/2/3623.rrd':'discards_in':AVERAGE
DEF:b='/var/www/cacti/rra/2/3623.rrd':'errors_in':AVERAGE
DEF:c='/var/www/cacti/rra/2/3623.rrd':'discards_out':AVERAGE
DEF:d='/var/www/cacti/rra/2/3623.rrd':'errors_out':AVERAGE
CDEF:cdefbh='a,UN,INF,UNKN,IF' LINE1:a#FFAB00FF:''
LINE1:b#F51D30FF:'' LINE1:c#C4FD3DFF:'' LINE1:d#00694AFF:''
COMMENT:'' AREA:cdefbh#8F9286FF:''

This results in "ERROR: Expected some arguments after 'COMMENT:'" and no
thumbnail displayed.

rrdtool -V
RRDtool 1.3.8 Copyright 1997-2009 by Tobias Oetiker <[email protected]>
Compiled Feb 23 2010 21:36:53


Why are there three COMMENT-arguments in this command?? The thoird one (empty COMMENT) results in the error.

How can we fix it?


Cheers
Christian

tkshamburg
Posts: 2
Joined: Thu Aug 08, 2013 2:12 am

Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra

#2 Post by tkshamburg » Thu Aug 08, 2013 6:51 am

Result from mailing-list:

It's a bug, Gandalf provide a patch for testing and I hope the final patch will be released soon.

If you are hurry: please look at the mailinglist at the moment :-)

Cheers
Christian

User avatar
gandalf
Developer
Posts: 22375
Joined: Thu Dec 02, 2004 2:46 am
Location: Muenster, Germany
Contact:

Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra

#3 Post by gandalf » Fri Aug 09, 2013 2:45 pm

This has been reported to the mantis bug tracker as well. The patch is available there and I will attach it here.
We are planning to publish a fixed version, soon (for those who do not like to use the "patch" command)

R.
Attachments
cacti088b_empty_comment.patch
(2.56 KiB) Downloaded 2316 times

ram1101
Posts: 11
Joined: Mon Jul 22, 2013 1:23 pm

Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra

#4 Post by ram1101 » Wed Sep 18, 2013 7:51 pm

how do I run the patch? new to centOS

ram1101
Posts: 11
Joined: Mon Jul 22, 2013 1:23 pm

Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra

#5 Post by ram1101 » Wed Sep 18, 2013 8:19 pm

I ran the patch and rebooted still no luck, what else do I need to do?

User avatar
gandalf
Developer
Posts: 22375
Joined: Thu Dec 02, 2004 2:46 am
Location: Muenster, Germany
Contact:

Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra

#6 Post by gandalf » Thu Sep 19, 2013 2:54 pm

Please post the whole rrdtool statement from Graph Management in debug mode
R.

ram1101
Posts: 11
Joined: Mon Jul 22, 2013 1:23 pm

Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra

#7 Post by ram1101 » Thu Sep 19, 2013 7:58 pm

crap how do I do that?

ram1101
Posts: 11
Joined: Mon Jul 22, 2013 1:23 pm

Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra

#8 Post by ram1101 » Thu Sep 19, 2013 8:00 pm

im really trying to learn this

RRDTool Command:

Notice: Undefined offset: 1 in /var/www/html/plugins/thold/setup.php on line 217

Notice: Undefined offset: 1 in /var/www/html/plugins/thold/setup.php on line 218
/usr/bin/rrdtool graph - \
--imgformat=PNG \
--start=-86400 \
--end=-60 \
--title='ASA CW 290 - CPU Usage' \
--rigid \
--base=1000 \
--height=120 \
--width=500 \
--alt-autoscale-max \
--lower-limit='0' \
--vertical-label='percent' \
--slope-mode \
--font TITLE:10: \
--font AXIS:8: \
--font LEGEND:8: \
--font UNIT:8: \
DEF:a='/var/www/html/rra/asa_cw_290_5min_cpu_503.rrd':'5min_cpu':AVERAGE \
--watermark "Created using CactiEZ" \
AREA:a#FF0000FF:'CPU Usage' \
GPRINT:a:LAST:'Current\:%8.0lf' \
GPRINT:a:AVERAGE:'Average\:%8.0lf' \
GPRINT:a:MAX:'Maximum\:%8.0lf\n' \
COMMENT:' \n' \
COMMENT:'Last Updated \: Thu 19 Sep 20\:00\:39 MDT 2013' RRDTool Says:

Notice: Undefined offset: 1 in /var/www/html/plugins/thold/setup.php on line 217

Notice: Undefined offset: 1 in /var/www/html/plugins/thold/setup.php on line 218
OK

User avatar
gandalf
Developer
Posts: 22375
Joined: Thu Dec 02, 2004 2:46 am
Location: Muenster, Germany
Contact:

Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra

#9 Post by gandalf » Sat Sep 21, 2013 2:16 am

This rrdtool statement does not show any error (apart from the issues caused by the thold plugin). How does the graph look like?
R.

atpt
Posts: 4
Joined: Sun Sep 08, 2013 8:30 am

Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra

#10 Post by atpt » Sat Sep 21, 2013 4:36 pm

I got the same error in graph D & F after I installed the ApacheStats_0.8.2 template. I tried the patch in cacti directory but I've got the following error message.

patch -p1 -N < cacti088b_empty_comment.patch
==========================================================================
can't find file to patch at input line 7
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|### Eclipse Workspace Patch 1.0
|#P cacti088
|Index: lib/rrd.php
|===================================================================
|--- lib/rrd.php (Revision 7407)
|+++ lib/rrd.php (Arbeitskopie)
--------------------------
File to patch:
Skip this patch? [y]
Skipping patch.
1 out of 1 hunk ignored
==========================================================================

RRDTool debug message
==========================================================================
RRDTool Command:

/usr/bin/rrdtool graph - \
--imgformat=PNG \
--start=-86400 \
--end=-300 \
--title='Localhost - Apache Stats - D - Bytes / Hit' \
--base=1024 \
--height=120 \
--width=500 \
--alt-autoscale-max \
--lower-limit='0' \
--vertical-label='bytes per hit' \
--slope-mode \
--font TITLE:10: \
--font AXIS:7: \
--font LEGEND:8: \
--font UNIT:7: \
DEF:a='/var/www/cacti-0.8.8b/rra/localhost_apache_total_kbytes_566.rrd':'apache_total_kbytes':AVERAGE \
DEF:b='/var/www/cacti-0.8.8b/rra/localhost_apache_total_hits_565.rrd':'apache_total_hits':AVERAGE \
CDEF:cdefa='a,UN,0,a,100000,GT,0,a,IF,IF' \
CDEF:cdefc='b,UN,0,b,100000,GT,0,b,IF,IF' \
CDEF:cdefe='cdefc,0,EQ,0,cdefa,1024,*,cdefc,/,IF,0,1000000,LIMIT' \
CDEF:cdefi='a,0,0,LIMIT' \
CDEF:cdefbc='b,0,0,LIMIT' \
COMMENT:'' \
COMMENT:'' \
COMMENT:'' \
COMMENT:'' \
AREA:cdefe#4123A1FF:'Bytes / Hit' \
GPRINT:cdefe:LAST:'Current\:%8.2lf %s' \
GPRINT:cdefe:AVERAGE:'Average\:%8.2lf %s' \
GPRINT:cdefe:MAX:'Maximum\:%8.2lf %s\n' \
LINE2:cdefi#FF0000FF:'kBytes' \
GPRINT:a:LAST:' Current\:%8.2lf %s' \
GPRINT:a:AVERAGE:'Average\:%8.2lf %s' \
GPRINT:a:MAX:'Maximum\:%8.2lf %s\n' \
LINE2:cdefbc#00FF00FF:'Hits' \
GPRINT:b:LAST:' Current\:%8.2lf %s' \
GPRINT:b:AVERAGE:'Average\:%8.2lf %s' \
GPRINT:b:MAX:'Maximum\:%8.2lf %s\n'

RRDTool Says:

ERROR: Expected some arguments after 'COMMENT:'

paulgevers
Cacti Pro User
Posts: 593
Joined: Tue Aug 29, 2006 4:09 pm
Location: NL

Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra

#11 Post by paulgevers » Sun Sep 22, 2013 10:19 am

atpt wrote:I got the same error in graph D & F after I installed the ApacheStats_0.8.2 template. I tried the patch in cacti directory but I've got the following error message.

patch -p1 -N < cacti088b_empty_comment.patch
==========================================================================
can't find file to patch at input line 7
So in which directory were you standing while applying this patch? Your -p level was wrong, or you were completely in the wrong location. Until you applied the patch correctly, don't expect this issue to resolve itself.
Maintainer of cacti in Debian (and Ubuntu).
Cacti 1.* is now officially supported on Debian Stretch via Debian backports
FAQ Ubuntu and Debian differences
Generic cacti debugging

atpt
Posts: 4
Joined: Sun Sep 08, 2013 8:30 am

Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra

#12 Post by atpt » Sun Sep 22, 2013 1:18 pm

paulgevers wrote:
atpt wrote:I got the same error in graph D & F after I installed the ApacheStats_0.8.2 template. I tried the patch in cacti directory but I've got the following error message.

patch -p1 -N < cacti088b_empty_comment.patch
==========================================================================
can't find file to patch at input line 7
So in which directory were you standing while applying this patch? Your -p level was wrong, or you were completely in the wrong location. Until you applied the patch correctly, don't expect this issue to resolve itself.
Thanks for your remind. I messed up my testing environment before. The patch can be apply without problem.

garyfarm
Posts: 4
Joined: Sun Aug 25, 2013 2:10 am

Re: cacti-0.8.8b: Multiple COMMENT arguments in "rrdtool gra

#13 Post by garyfarm » Sat Mar 08, 2014 3:56 pm

To fix the no thumbnail graphs showing when checking the thumbnail box.

THANK YOU to user sdavied for posting a patch file in another post. What some people may be missing that are relatively "novice" users of Cacti is how "exactly" to apply it.

If you installed the EZCacti use the Cacti WebAdmin at http://<ipaddress>:10000 in a web browser and go to the "Upload and download" topic on the left colum. Here is where you upload the patch to your server that user sdavied uploaded earlier. Upload the patch file to the directory /var/www/html Remember this does not apply the patch, it only sends it to the server.

You can use the SSH tool in the WebAdmin that you just used, but I find it easier to go the terminal of your server either sitting right at it or by ssh. Issue the command cd /var/www/html and hit return. It should return to a prompt with html in it. Then type patch -p0 -b < rrd.php.patch and hit enter. This should return to the same html prompt that you were just at.....with no errors.

That's it. Go back to your Cacti webpage and do a page refresh and click on the "Thumbnails" checkbox and you will see your graphs again for the first time in months !

Just in case I attached sdavied file from a previous post.

Hope this helps a lot of people....it worked for me.

Gary
Attachments
rrd.php.patch
(2.5 KiB) Downloaded 941 times

Post Reply