Graph templates for Squid

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Post Reply
Author
Message
Makenshi

Graph templates for Squid

#1 Post by Makenshi » Tue Jun 08, 2004 5:33 am

I have made templates for the following:-

HTTP Requests (requests per second)
HTTP Traffic (kilobytes per second)
Cache object (objects)

See them in action here.

Makenshi
Posts: 26
Joined: Tue Jun 08, 2004 5:34 am

#2 Post by Makenshi » Tue Jun 08, 2004 5:38 am

Forgot to log in. Added the templates to this post.
Attachments
cacti_graph_template_squid_http_requests.xml
Squid - HTTP Requests
(9.87 KiB) Downloaded 13275 times
cacti_graph_template_squid_http_data.xml
Squid - HTTP Traffic
(15.15 KiB) Downloaded 13818 times
cacti_graph_template_squid_cache_objects.xml
Squid - Cache Objects
(9.54 KiB) Downloaded 19409 times

Makenshi
Posts: 26
Joined: Tue Jun 08, 2004 5:34 am

#3 Post by Makenshi » Thu Jun 10, 2004 4:22 am

The server is temporarily offline due to an upgrade issue. That'll teach me to do it remotely. If I wasn't off sick it would have been fixed by now. I shall take a trip in to fix it this evening.

fish
Posts: 10
Joined: Tue Nov 09, 2004 12:28 am

#4 Post by fish » Tue Feb 15, 2005 10:27 am

i think it should has data field for snmp port coz squid use 3401 for its snmp so perhaps you should re adjust the scripts. how is it bro ?
your script was so cool!

thesg
Posts: 4
Joined: Fri Feb 18, 2005 10:06 am

using

#5 Post by thesg » Fri Feb 18, 2005 11:45 am

I'm using all three of these.. working GREAT!

THANKS!

kfradley
Posts: 4
Joined: Tue Feb 22, 2005 8:47 pm

Squid Issues

#6 Post by kfradley » Tue Feb 22, 2005 8:52 pm

:evil:
I have the MIB and CFG file I have used to mointoring squid proxy service on port 3041 but how do I import that or get Cacti to reconize it?
I go to devices and try to query it but get SNMP error.
Any ideas will greatly help me, thank you.

kfradley
Posts: 4
Joined: Tue Feb 22, 2005 8:47 pm

Sorry

#7 Post by kfradley » Tue Feb 22, 2005 8:53 pm

The CFG File and MIB I use are with MRTG. It works fine with it but dunno how to import the MIB?

joecen
Posts: 15
Joined: Wed Mar 02, 2005 10:40 am

#8 Post by joecen » Thu Apr 07, 2005 10:02 pm

Makenshi wrote:Forgot to log in. Added the templates to this post.
hi,Makenshi.
I add your three templates and created a new host template.
After I added a new squid driver ,I saw "snmp error" in my device and the data source hadn't been created.
I use

Code: Select all

snmpwalk -v 1 -c xxx 10.23.8.1:3401 .1.3.6.1.4.1.3495.1.3.2.1.4
response:

Code: Select all

SNMPv2-SMI::enterprises.3495.1.3.2.1.4.0 = Counter32: 731757
so I think my setting of squid is right.

how could I do?
Attachments
squidsnmp.JPG
squidsnmp.JPG (69.53 KiB) Viewed 120371 times

Makenshi
Posts: 26
Joined: Tue Jun 08, 2004 5:34 am

#9 Post by Makenshi » Fri Apr 08, 2005 2:36 am

From the look of it, the problem is that Cacti cannot communicate with the snmp agent. First you need to check if your Squid has been compiled with snmp support. Also, you will need the correct directives for snmp in squid.conf. An example of these are:-

snmp_port 3401
acl snmppublic snmp_community public
snmp_access allow snmppublic
snmp_incoming_address 0.0.0.0
snmp_outgoing_address 255.255.255.255

Hope this helps!

PKLNTKJ334
Posts: 9
Joined: Mon May 02, 2005 12:14 pm
Location: Brazil
Contact:

#10 Post by PKLNTKJ334 » Thu May 05, 2005 9:05 am

hi all,

I am trying to graph my two squid servers, but with no lucky. One machine is running redhat9, so i checked squid src rpm and the squid.spec already had a configure option to --enable-snmp. So i think that my squid is fine, snmp enabled.

I edited the squid.conf and added the lines:

snmp_port 3401
acl snmppublic snmp_community public
snmp_access allow snmppublic
snmp_incoming_address 0.0.0.0
snmp_outgoing_address 255.255.255.255

and then restarted squid, but no graph at all.

Any idea of what else should be done for getting the squid graphs??

thanks in advance,
Clovis Sena

PKLNTKJ334
Posts: 9
Joined: Mon May 02, 2005 12:14 pm
Location: Brazil
Contact:

#11 Post by PKLNTKJ334 » Thu May 05, 2005 11:32 am

extra info:

running manually:

[[email protected] csena]$ snmpwalk -v 1 -c public 10.0.1.9:3401 .1.3.6.1.4.1.3495.1.3.2.1
SNMPv2-SMI::enterprises.3495.1.3.2.1.1.0 = Counter32: 96557
SNMPv2-SMI::enterprises.3495.1.3.2.1.2.0 = Counter32: 44533
SNMPv2-SMI::enterprises.3495.1.3.2.1.3.0 = Counter32: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.4.0 = Counter32: 39046
SNMPv2-SMI::enterprises.3495.1.3.2.1.5.0 = Counter32: 499309
SNMPv2-SMI::enterprises.3495.1.3.2.1.6.0 = Counter32: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.7.0 = Counter32: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.8.0 = Counter32: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.9.0 = Counter32: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.10.0 = INTEGER: 61479
SNMPv2-SMI::enterprises.3495.1.3.2.1.11.0 = INTEGER: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.12.0 = Counter32: 433979
SNMPv2-SMI::enterprises.3495.1.3.2.1.13.0 = Counter32: 32112
SNMPv2-SMI::enterprises.3495.1.3.2.1.14.0 = Counter32: 138238
SNMPv2-SMI::enterprises.3495.1.3.2.1.15.0 = Counter32: 117


and on another machine:

[[email protected] csena]$ snmpwalk -v 1 -c public 10.0.1.10:3401 .1.3.6.1.4.1.3495.1.3.2.1
SNMPv2-SMI::enterprises.3495.1.3.2.1.1.0 = Counter32: 888
SNMPv2-SMI::enterprises.3495.1.3.2.1.2.0 = Counter32: 272
SNMPv2-SMI::enterprises.3495.1.3.2.1.3.0 = Counter32: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.4.0 = Counter32: 538
SNMPv2-SMI::enterprises.3495.1.3.2.1.5.0 = Counter32: 3784
SNMPv2-SMI::enterprises.3495.1.3.2.1.6.0 = Counter32: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.7.0 = Counter32: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.8.0 = Counter32: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.9.0 = Counter32: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.10.0 = INTEGER: 639
SNMPv2-SMI::enterprises.3495.1.3.2.1.11.0 = INTEGER: 0
SNMPv2-SMI::enterprises.3495.1.3.2.1.12.0 = Counter32: 3692
SNMPv2-SMI::enterprises.3495.1.3.2.1.13.0 = Counter32: 433
SNMPv2-SMI::enterprises.3495.1.3.2.1.14.0 = Counter32: 92148
SNMPv2-SMI::enterprises.3495.1.3.2.1.15.0 = Counter32: 1


as I see, squid snmp is working, but I still can't have graph data.

any idea??

PKLNTKJ334
Posts: 9
Joined: Mon May 02, 2005 12:14 pm
Location: Brazil
Contact:

#12 Post by PKLNTKJ334 » Fri May 06, 2005 1:10 pm

I am making some more tests here and I would like to know if cacti is reaally using other port than default port 161...

How could I check this??

User avatar
Morgan
Cacti User
Posts: 187
Joined: Wed Feb 25, 2004 3:38 am
Contact:

#13 Post by Morgan » Tue May 10, 2005 10:43 am

i posted a host template for bluecoat proxies. this should work on squid as they use the same mibs.

a brave soul should use the search button to find it.

Morgan

PKLNTKJ334
Posts: 9
Joined: Mon May 02, 2005 12:14 pm
Location: Brazil
Contact:

#14 Post by PKLNTKJ334 » Wed May 11, 2005 8:36 am

hi all,

searching the forums, I've found this:

http://forums.cacti.net/viewtopic.php?t ... =port+3401

-----------------------------------------
You can configure your snmpd.conf file to passthrough snmp queries like ...

proxy -v 1 -c <communityname> <squid_machine>:3401 .1.3.6.1.4.1.3495.1

In my case -

proxy -v 1 -c public localhost:3401 .1.3.6.1.4.1.3495.1

Hope this helps.

-P
----------------------------------------

This worked for me. Now I am getting my squid data beeing graphed.

I hope it helps somebody else.

:wink:


Clovis.

r_chetanjain
Cacti User
Posts: 83
Joined: Fri Aug 22, 2003 4:33 am

problem with graphs

#15 Post by r_chetanjain » Tue Jul 05, 2005 12:23 pm

my cacti.log shows up

7/05/2005 10:55:03 PM - CMDPHP: Poller[0] Host[4] DS[13] WARNING: Result from SNMP not valid. Partial Result:
07/05/2005 10:55:03 PM - CMDPHP: Poller[0] Host[4] DS[14] WARNING: Result from SNMP not valid. Partial Result:
07/05/2005 10:55:03 PM - CMDPHP: Poller[0] Host[4] DS[15] WARNING: Result from SNMP not valid. Partial Result:
07/05/2005 10:55:03 PM - CMDPHP: Poller[0] Host[4] DS[16] WARNING: Result from SNMP not valid. Partial Result:

what this error means

Post Reply