Discovery not resolving ip

General discussion about Plugins for Cacti

Moderators: Moderators, Developers

Post Reply
Author
Message
Rno
Cacti User
Posts: 350
Joined: Wed Dec 07, 2011 9:19 am

Discovery not resolving ip

#1 Post by Rno » Wed Aug 17, 2016 9:03 am

Hello,
my discovery plug in won't resolve my Ip address, so the field hostname containe the IP instead of the FQDN.
Or whta's how it' suppose to work ?

thanks for the input
CentOS
Production
Cacti 0.8.8h
Spine 0.8.8h
PIA 3.1
Aggregate 0.75
Monitor 1.3
Settings 0.71
Weathermap 0.98
Thold 0.5
rrdclean 0.41

Own plugin: LinkDiscovery 0.45, Map 0.37

Test
Cacti 1.2.6
Spine 1.2.6
thold 1.0.6
monitor 2.3.5
php 7.2.11
mariadb 5.5.56
Own plugin:
ExtendDB 1.1.2
LinkDiscovery 1.2.6
Map 1.2.6

cigamit
Developer
Posts: 2786
Joined: Thu Apr 07, 2005 3:29 pm
Location: B/CS Texas
Contact:

Re: Discovery not resolving ip

#2 Post by cigamit » Sun Aug 28, 2016 10:23 am

It should be resolving it, you may have to check your DNS Settings to ensure that the DNS Server listed can actually reverse resolve the IP.

Rno
Cacti User
Posts: 350
Joined: Wed Dec 07, 2011 9:19 am

Re: Discovery not resolving ip

#3 Post by Rno » Mon Aug 29, 2016 1:59 am

DNS is working fine thanks
CentOS
Production
Cacti 0.8.8h
Spine 0.8.8h
PIA 3.1
Aggregate 0.75
Monitor 1.3
Settings 0.71
Weathermap 0.98
Thold 0.5
rrdclean 0.41

Own plugin: LinkDiscovery 0.45, Map 0.37

Test
Cacti 1.2.6
Spine 1.2.6
thold 1.0.6
monitor 2.3.5
php 7.2.11
mariadb 5.5.56
Own plugin:
ExtendDB 1.1.2
LinkDiscovery 1.2.6
Map 1.2.6

Post Reply