Plugins not compatible

Addons for Cacti and discussion about those addons

Moderators: Moderators, Developers

Post Reply
Author
Message
gswiney
Posts: 16
Joined: Tue Jul 04, 2017 8:11 pm

Plugins not compatible

#1 Post by gswiney » Tue Jul 04, 2017 8:19 pm

I installed Cacti v1.1.11 on a Centos 7 server and all the plugins I try give me "Not Compatible, Legacy Plugin" in the Plugin Management section of cacti. I have installed thold, mactrack, syslog, and monitor. Any ideas as to how I can resolve this.
Cacti Plugins.png
Cacti Plugins.png (12.12 KiB) Viewed 1656 times

cigamit
Developer
Posts: 2771
Joined: Thu Apr 07, 2005 3:29 pm
Location: B/CS Texas
Contact:

Re: Plugins not compatible

#2 Post by cigamit » Tue Jul 04, 2017 10:32 pm

First, upgrade to 1.12, as it fixed an issue with installing plugins.
Second, make sure you are using the plugins from Github.

gswiney
Posts: 16
Joined: Tue Jul 04, 2017 8:11 pm

Re: Plugins not compatible

#3 Post by gswiney » Wed Jul 05, 2017 8:02 pm

thanks for the help. I have gotten a little farther. now the plugin loads but when I try to install it from the Plugin Manager I get:

Validation error for variable id, with value of "plugin_monitor-develop". See backtrace below for more details.
(/plugins.php: 51 get_filter_request_var)(/lib/html_utility.php: 433 die_html_input_error)(/lib/html_validate.php: 60 cacti_debug_backtrace)

gswiney
Posts: 16
Joined: Tue Jul 04, 2017 8:11 pm

Re: Plugins not compatible

#4 Post by gswiney » Wed Jul 05, 2017 8:21 pm

Nevermind. re-read the instructions and renamed the file as directed and it now works. Thanks again for the help.

Post Reply