Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Mon Apr 22, 2019 1:56 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 19 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: AIX Monitoring Template via NMON
PostPosted: Tue Jul 24, 2012 2:55 am 
Offline

Joined: Wed May 16, 2012 5:35 am
Posts: 13
I don't understand how I can add graphs for e.g. IO Adapter usage properly.

Is this correct?

I go to Devices, select the desired AIX server and add an Associated Data Source for IO Adapter Statistics (what should I select in the Re-Index Method dropdown?).

If I click "Verbose Query" I get this:

Data Query Debug Information
+ Running data query [30].
+ Found type = '4' [Script Query].
+ Found data query XML file at '/usr/share/cacti/resource/script_queries/nmon_ioadapt.xml'
+ Error parsing XML file into an array.
+ Found data query XML file at '/usr/share/cacti/resource/script_queries/nmon_ioadapt.xml'
+ Found data query XML file at '/usr/share/cacti/resource/script_queries/nmon_ioadapt.xml'
+ Found data query XML file at '/usr/share/cacti/resource/script_queries/nmon_ioadapt.xml'

I get this error with all of the Graph Templates I can choose from (even cumulative CPU statistics, although that one works fine from the New Graphs guide.

My nmon_ioadapt.xml looks like this:

Code:
<interface>
        <name>NMON IO Adapter Statistics</name>
        <description>Reads out IO Adapter statistics using NMON</description>
        <script_path>/usr/bin/perl |path_cacti|/scripts/query_nmon.pl</script_path>
        <arg_prepend>|host_hostname| IOADAPT</arg_prepend>
        <arg_index>index</arg_index>
        <arg_query>query</arg_query>
        <arg_get>get</arg_get>
        <arg_num_indexes>num_indexes</arg_num_indexes>
        <output_delimeter>:</output_delimeter>
        <index_order>IOAdaptDevice</index_order>
        <index_order_type>numeric</index_order_type>
        <index_title_format>|chosen_order_field|</index_title_format>

        <fields>
                <IOAdaptDevice>
                        <name>Device Name</name>
                        <direction>input</direction>
                        <query_name>device</query_name>
                </IOAdaptDevice>
                <IOAdaptXfer>
                        <name>Transfers/s</name>
                        <direction>output</direction>
                        <query_name>xfer-tps</query_name>
                </IOAdaptXfer>
                <IOAdaptWriteKB>
                        <name>Write KB/s</name>
                        <direction>output</direction>
                        <query_name>write-kbps</query_name>
                </IOAdaptWriteKB>
                <IOAdaptReadKB>
                        <name>Read KB/s</name>
                        <direction>output</direction>
                        <query_name>read-kbps</query_name>
                </IOAdaptReadKB>
        </fields>
</interface>


Top
 Profile  
 
 Post subject: Re: AIX Monitoring Template via NMON
PostPosted: Wed Sep 05, 2012 9:00 pm 
Offline

Joined: Wed Sep 05, 2012 7:46 pm
Posts: 1
Thanks for the template, it seems to be working exactly as documented. I am however having a problem. It looks like there are intermittent issues when extracting data. I am getting the following message: Cannot open /usr/local/nagios/libexec/nmon.pattern, and then a whole lot of "Use of uninitialized value $attr in substitution" messages. This is random, for the most part data is extracted expected. You can see the result of these command problems below:

Image


Top
 Profile  
 
 Post subject: Re: AIX Monitoring Template via NMON
PostPosted: Fri Oct 05, 2012 3:20 pm 
Offline

Joined: Fri Oct 05, 2012 3:15 pm
Posts: 1
I am not able to see any graphs for jfs, disk, or ioadapt. When I run the query from cli I do get output back. what could be the problem in Cacti?


Top
 Profile  
 
 Post subject: Re: AIX Monitoring Template via NMON
PostPosted: Mon Aug 07, 2017 9:29 pm 
Offline

Joined: Mon Aug 07, 2017 9:17 pm
Posts: 1
Hi Guys, I'm new with cacti and in this forum too, so sorry if i made any mistake posting. :)

I'm configuring cacti to monitor performace and usage for aix and linux servers.
I Follow this post and some other information and works pretty well!!
The problem i'm facing now is with some Virtual IO Servers, i have configured them as normal AIX servers and i can't get the npiv Fibre Channel adapters performance graph.
I don't know if it is a nmon configuration (i have tried with the -^ option )
/usr/bin/topas_nmon -f -s 30 -a 7 -t -L -A -w 4 -l 150 -I 0.1 -^ -m /tmp/nmon

Maybe the problem is with the nmon parse script...

Any help would be appreciated. Thank you!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 19 posts ]  Go to page Previous  1, 2

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group