Pre-Installation Checks - LDAP Installed but still "NO"

Post support questions that relate to the Windows 2003/2000/XP operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
morijlumos2
Posts: 2
Joined: Mon Jan 08, 2018 1:34 pm

Pre-Installation Checks - LDAP Installed but still "NO"

#1 Post by morijlumos2 » Mon Jan 08, 2018 2:05 pm

The last thing I need for all the installation checks is to get LDAP installed.
as you can see in the screenshots, also i confirmed the proper dll's are in place.
I am not sure what else to do, and why it is not registering as Installed.

Image
Image

Using Windows 7 (test env)
Apache 2.4.9
Mysql5.6.17
php5.5.12

netniV
Cacti Guru User
Posts: 2670
Joined: Sun Aug 27, 2017 12:05 am

Re: Pre-Installation Checks - LDAP Installed but still "NO"

#2 Post by netniV » Mon Jan 08, 2018 4:44 pm

You probably need to run one of the following (assuming its ubuntu) depending on the system you are running.

Code: Select all

php7enmod ldap 
php7enmod php-ldap
phpenmod ldap
phpenmod php-ldap
I've included all four because it changes between some systems and I can't recall if you need the php- in front of the mod name or not off the top of my head. Once you've done that you need to reload apache.

morijlumos2
Posts: 2
Joined: Mon Jan 08, 2018 1:34 pm

Re: Pre-Installation Checks - LDAP Installed but still "NO"

#3 Post by morijlumos2 » Tue Jan 09, 2018 1:23 pm

I actually got this working, I found this useful comment on stackexchange and it worked.

https://stackoverflow.com/a/46560708/1787465

"after enabling extension =php_ldap.dll in php.ini

you must add following dll to system32 in windows

copy libsasl.dll into system32 folder

steps: php.ini enable ;extension =php_ldap.dll --> extension =php_ldap.dll

copy libsasl.dll from php folder and paste it in system32

windows-->system32--> paste libsasl.dll

Incase it does not work and also add libeay32.dll and ssleay32.dll."

netniV
Cacti Guru User
Posts: 2670
Joined: Sun Aug 27, 2017 12:05 am

Re: Pre-Installation Checks - LDAP Installed but still "NO"

#4 Post by netniV » Tue Jan 09, 2018 2:05 pm

Ah, apologies, didn't realise that you were running this on windows.

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

Re: Pre-Installation Checks - LDAP Installed but still "NO"

#5 Post by BSOD2600 » Mon Jan 15, 2018 1:41 am

morijlumos2 wrote:copy libsasl.dll into system32 folder
....
In case it does not work and also add libeay32.dll and ssleay32.dll."
This is exactly what the Windows Installer does for a user ;)

libsasl.dll, libeay32.dll, ssleay32.dll are all in the PHP folder.

imagica
Posts: 3
Joined: Tue May 02, 2017 9:52 pm

Re: Pre-Installation Checks - LDAP Installed but still "NO"

#6 Post by imagica » Fri Apr 20, 2018 7:07 am

I have copied all the files in system32 directory but still upgradation from 1.1.37 to 1.1.38 shows error for "ldap" and "openssl" as not installed. both plugin extension are already enabled in php.ini as well.

Post Reply