Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Tue Jul 16, 2019 9:37 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: noSuchInstance in SNMP polls
PostPosted: Thu Dec 27, 2018 12:37 pm 
Offline

Joined: Thu Dec 27, 2018 12:27 pm
Posts: 2
I'm using 1.1.37, with net-snmp 5.7.2r37. Using cmd.php as the poller, since I don't think I'm polling enough nodes to warrant the binary poller.

A large number of oids based on an XML data query that I wrote are returning noSuchInstance errors. I'm looking at the polling using wireshark to determine this response. When I craft a similar request on the command line using "snmpget", I get an appropriate, numeric response. I've put up the request packet side-by-side between a poll from cmd.php and one that I did from the shell. Down to the byte, besides the obvious difference of the request-id, I see no difference whatsoever between an snmp-get from the poller and one from my tests. But the poller fails, and my tests succeed. I'm at my wit's end. Any ideas?


** UPDATE **

I've since upgraded to 1.1.38 and switched to the spine poller. No improvement.


Top
 Profile  
 
 Post subject: Re: noSuchInstance in SNMP polls
PostPosted: Fri Dec 28, 2018 3:46 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 2585
Have you put the device into debug mode to see the output in the cacti log?

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: noSuchInstance in SNMP polls
PostPosted: Mon Dec 31, 2018 7:57 am 
Offline

Joined: Thu Dec 27, 2018 12:27 pm
Posts: 2
Yes, obviously. It was done before the packet capture, and told me that the value of the query was "U". That's what prompted my more in-depth troubleshooting. Is there something specific you want me to look for?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group