1.2.0 still has "Spike Kill" problems on FreeBSD

Post general support questions here that do not specifically fall into the Linux or Windows categories.

Moderators: Moderators, Developers

Post Reply
Author
Message
tickerguy
Posts: 11
Joined: Wed Jan 06, 2010 10:04 pm

1.2.0 still has "Spike Kill" problems on FreeBSD

#1 Post by tickerguy » Thu Jan 10, 2019 9:37 am

Running from the packages and updated to 1.2.0 yesterday.

I had commented out the spike kill logic as referred to here due to the interaction with php72 that appeared to cause some problems: https://github.com/Cacti/cacti/issues/1663

This is marked "fixed".

It is not on FreeBSD under 1.2.0; as soon as I updated the problem came back (since the code files got updated again and my commented-out lines were of course re-activated.)

2019/01/10 08:25:00 - PING Device[16] SNMP: Device responded to SNMP
2019/01/10 08:25:00 - POLLER: Poller[1] Device[16] STATUS: Device 'ipgw-inside.d
enninger.net' is UP.
2019/01/10 08:25:00 - POLLER: Poller[1] Device[16] RECACHE: Processing 2 items i
n the auto reindex cache for 'ipgw-inside.denninger.net'.
2019/01/10 08:25:00 - POLLER: Poller[1] Device[16] DQ[1] RECACHE OID: .1.3.6.1.2
.1.1.3.0, (assert:5578105 < output:0:15:33:33.26)
2019/01/10 08:25:00 - POLLER: Poller[1] Device[16] DQ[1] RECACHE ASSERT FAILED '
5578105<0:15:33:33.26
2019/01/10 08:25:00 - POLLER: Poller[1] Device[16] NOTICE: Spike Kill in Effect
for 'ipgw-inside.denninger.net'.
2019/01/10 08:25:00 - POLLER: Poller[1] Device[16] DQ[9] RECACHE OID: .1.3.6.1.2
.1.1.3.0, (assert:5573660 < output:0:15:33:33.27)
2019/01/10 08:25:00 - POLLER: Poller[1] Device[16] DQ[9] RECACHE ASSERT FAILED '
5573660<0:15:33:33.27
2019/01/10 08:25:00 - POLLER: Poller[1] Device[16] NOTICE: Spike Kill in Effect
for 'ipgw-inside.denninger.net'.

Commenting out the lines referred to on Github once again restored the collection and graphing, but it's not really "fixed"; I'm just masking it.

Any ideas?

User avatar
Osiris
Cacti Pro User
Posts: 887
Joined: Mon Jan 05, 2015 10:10 am

Re: 1.2.0 still has "Spike Kill" problems on FreeBSD

#2 Post by Osiris » Thu Jan 10, 2019 6:00 pm

This may have more to do with php-snmp then it does with Cacti. Test with php-snmp uninstalled and provide feedback.
Before history, there was a paradise, now dust.

User avatar
Osiris
Cacti Pro User
Posts: 887
Joined: Mon Jan 05, 2015 10:10 am

Re: 1.2.0 still has "Spike Kill" problems on FreeBSD

#3 Post by Osiris » Thu Jan 10, 2019 6:00 pm

Also, state your version of php as well.
Before history, there was a paradise, now dust.

tickerguy
Posts: 11
Joined: Wed Jan 06, 2010 10:04 pm

Re: 1.2.0 still has "Spike Kill" problems on FreeBSD

#4 Post by tickerguy » Thu Jan 10, 2019 10:47 pm

PHP 7.2.13 (cli) (built: Dec 9 2018 01:14:11) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies

Building from packages (or ports, due to dependencies) I can't remove php-snmp because doing so removes cacti as it is listed as a direct dependency:

[email protected]:/disk/karl # pkg delete php72-snmp
Checking integrity... done (0 conflicting)
Deinstallation has been requested for the following 2 packages (of 0 packages in the universe):

Installed packages to be REMOVED:
php72-snmp-7.2.13
cacti-1.2.0

Number of packages to be removed: 2

The operation will free 50 MiB.

Proceed with deinstalling packages? [y/N]:

I can force that to be ignored and will attempt that -- is the consensus that I should request that FreeBSD not include the php-snmp module as a dependency (and in fact require it NOT be installed?)

netniV
Cacti Guru User
Posts: 3027
Joined: Sun Aug 27, 2017 12:05 am

Re: 1.2.0 still has "Spike Kill" problems on FreeBSD

#5 Post by netniV » Fri Jan 11, 2019 1:57 pm

It should be installed with Cacti but it should not mean cacti is uninstalled because of it. In most circumstances, the use of PHP-SNMP is generally OK but we have found certain people fair better with it removed. Alternatively, rather than uninstall the package, you could just disable the use of PHP-SNMP in the configuration (normally in /usr/local/etc/php/extensions.ini )

User avatar
Osiris
Cacti Pro User
Posts: 887
Joined: Mon Jan 05, 2015 10:10 am

Re: 1.2.0 still has "Spike Kill" problems on FreeBSD

#6 Post by Osiris » Fri Jan 11, 2019 4:30 pm

So, you need to disable quick print in the API when performing snmp get requests. Looks like PHP SNMP is fixing some of the deficiencies in more recent releases. Let me check a few things.
Before history, there was a paradise, now dust.

User avatar
Osiris
Cacti Pro User
Posts: 887
Joined: Mon Jan 05, 2015 10:10 am

Re: 1.2.0 still has "Spike Kill" problems on FreeBSD

#7 Post by Osiris » Fri Jan 11, 2019 4:44 pm

Edit lib/snmp.php, change line 74 from SNMP_VALUE_LIBRARY to SNMP_VALUE_PLAIN, then save the file. Problem solved I think.
Before history, there was a paradise, now dust.

Post Reply