ERROR: Problems parsing Multi SNMP OID!

Post support questions that directly relate to Linux/Unix operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
battossai
Posts: 14
Joined: Sun Sep 27, 2015 11:46 pm

ERROR: Problems parsing Multi SNMP OID!

#1 Post by battossai » Mon Jan 21, 2019 9:21 am

Hi,


I have upgrade to cacti 1.2.1 in some devices is not showing any graph.
The only clue that i have is :

ERROR: Problems parsing Multi SNMP OID! bla bla bla


Any idea to solve this ?
Thank you in advanced.


Regards,
Franky

bartman0023
Posts: 2
Joined: Thu Apr 12, 2012 12:05 pm

Re: ERROR: Problems parsing Multi SNMP OID!

#2 Post by bartman0023 » Tue Jan 22, 2019 10:53 am

Same problem I try to upgrade from cacti 1.1.38 to 1.2.0 or 1.2.1 and when I try to look the graphs don't show any.

bartman0023
Posts: 2
Joined: Thu Apr 12, 2012 12:05 pm

Re: ERROR: Problems parsing Multi SNMP OID!

#3 Post by bartman0023 » Tue Jan 22, 2019 11:25 am

Hi I found the solution the problem was on the file in cacti/lib/html_tree.php

The right code is

https://github.com/Cacti/cacti/blob/4fc ... l_tree.php

8)

netniV
Cacti Guru User
Posts: 2685
Joined: Sun Aug 27, 2017 12:05 am

Re: ERROR: Problems parsing Multi SNMP OID!

#4 Post by netniV » Tue Jan 22, 2019 12:55 pm

I doubt that is the right code as that is old and in the middle of the beta's. I would not advise using that.

battossai
Posts: 14
Joined: Sun Sep 27, 2015 11:46 pm

Re: ERROR: Problems parsing Multi SNMP OID!

#5 Post by battossai » Wed Jan 23, 2019 9:23 am

So what should i do ?
Just a few devices that not shown the graphs

sirius1986
Posts: 2
Joined: Thu Feb 07, 2019 8:05 am

Re: ERROR: Problems parsing Multi SNMP OID!

#6 Post by sirius1986 » Thu Feb 07, 2019 8:06 am

The same problem after updating to 1.2.1. How to solve this have no idea, anyone could help?

User avatar
Osiris
Cacti Pro User
Posts: 835
Joined: Mon Jan 05, 2015 10:10 am

Re: ERROR: Problems parsing Multi SNMP OID!

#7 Post by Osiris » Thu Feb 07, 2019 6:08 pm

Please update lib/data_query.php and lib/functions.php from the develop branch in GitHub and then re-index your devices. There was a bug in 1.2.1 that will be addressed shortly in 1.2.2.
Before history, there was a paradise, now dust.

sirius1986
Posts: 2
Joined: Thu Feb 07, 2019 8:05 am

Re: ERROR: Problems parsing Multi SNMP OID!

#8 Post by sirius1986 » Fri Feb 08, 2019 3:02 am

I found the solution. Look into your log, find the name of the device with this error and check out data sources of it graphs. Look into indextype and indexvalue fields, in my case in indexvalue was ifalias and in value was full switch name, the same was in all device graphs, which cause an errors of multiple similar oids.

Post Reply