Reporting issue - multiple recipients

Post support questions that directly relate to Linux/Unix operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
penguin
Posts: 5
Joined: Thu Jan 31, 2019 4:53 am

Reporting issue - multiple recipients

#1 Post by penguin » Thu Jan 31, 2019 5:09 am

I've recently set up the reporting function to send a daily e-mail with a few graphs on there. Whilst this overall works, I've got an issue with sending this to multiple recipients. The report always goes to the first contact listed, however it doesn't send to either additional addresses (separated by commas) or to any of the bcc addresses. I've tried various combinations of this and the cacti logs only show the first address being sent to, as does the mail server logs. Am I missing something obvious or is this a bug (currently running v1.2.1)?


User avatar
Osiris
Cacti Pro User
Posts: 835
Joined: Mon Jan 05, 2015 10:10 am

Re: Reporting issue - multiple recipients

#3 Post by Osiris » Sun Feb 03, 2019 7:45 am

There have been reports of some special characters causing issues with email addresses. They have been corrected in develop. Are those emails containing special characters?
Before history, there was a paradise, now dust.

penguin
Posts: 5
Joined: Thu Jan 31, 2019 4:53 am

Re: Reporting issue - multiple recipients

#4 Post by penguin » Fri Feb 15, 2019 9:38 am

This is using the built in reporting. There are no special characters in the e-mail addresses (aside from a dash which should be fine).

It sends to the first recipient, but no others. For testing I've entered a second (comma separated) address to the 'to' address box where the first recipient always gets the e-mail and also added one separately to the 'bcc' box. The logs don't even mention these addresses aside from the first one (addresses substituted):

2019/02/15 07:00:06 - MAILER INFO: Mail successfully sent from 'Cacti Monitoring <[email protected]>', to '[email protected]', cc '', Subject 'Transit Report'

So [email protected] does receive the message, but the second comma separated to address or the bcc adddress do not receive anything nor are they mentioned in the logs

netniV
Cacti Guru User
Posts: 2691
Joined: Sun Aug 27, 2017 12:05 am

Re: Reporting issue - multiple recipients

#5 Post by netniV » Fri Feb 15, 2019 9:54 am

If you try the following, do you see the correct values?

Code: Select all

select id,enabled,subject,email from reports;

penguin
Posts: 5
Joined: Thu Jan 31, 2019 4:53 am

Re: Reporting issue - multiple recipients

#6 Post by penguin » Fri Feb 15, 2019 10:05 am

The two main recipients are displayed, but not he bcc:

Code: Select all

MariaDB [cacti]> select id,enabled,subject,email from reports;
+----+---------+--------------------------------+----------------------------------------------+
| id | enabled | subject                        | email                                        |
+----+---------+--------------------------------+----------------------------------------------+
|  1 |         | Test Report      | [email protected]                         |
|  2 |         | Test Report 2   | [email protected]                         |
|  3 | on      | Transit Report | [email protected],[email protected] |
+----+---------+--------------------------------+----------------------------------------------+
3 rows in set (0.00 sec)
user2 never receives the report, nor are they in the logs
Last edited by netniV on Fri Feb 15, 2019 10:19 am, edited 1 time in total.
Reason: Added code formatting.

netniV
Cacti Guru User
Posts: 2691
Joined: Sun Aug 27, 2017 12:05 am

Re: Reporting issue - multiple recipients

#7 Post by netniV » Fri Feb 15, 2019 10:20 am

BCC is in the 'bcc' field which we didn't have in the select statement.

penguin
Posts: 5
Joined: Thu Jan 31, 2019 4:53 am

Re: Reporting issue - multiple recipients

#8 Post by penguin » Sat Feb 16, 2019 6:11 pm

OK, that makes sense. The recipients are showing in the database correctly though so odd that they are not being logged or e-mailed.

netniV
Cacti Guru User
Posts: 2691
Joined: Sun Aug 27, 2017 12:05 am

Re: Reporting issue - multiple recipients

#9 Post by netniV » Sun Feb 17, 2019 8:49 am

Can you open this as a support issue on GitHub and include the select data example, that way we can log and track it.

penguin
Posts: 5
Joined: Thu Jan 31, 2019 4:53 am

Re: Reporting issue - multiple recipients

#10 Post by penguin » Mon Feb 18, 2019 12:22 pm

No problem, logged under #2427

Cheers

Post Reply