[SOLVED]First Step of cacti-1.2.2 install fails

Post support questions that directly relate to Linux/Unix operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
eholz1
Cacti User
Posts: 129
Joined: Mon Oct 01, 2018 10:09 am

[SOLVED]First Step of cacti-1.2.2 install fails

#1 Post by eholz1 » Thu Mar 21, 2019 4:37 pm

Hello All,

I had this error when I tried to install cacti-1.2.1 as well - could never get 1.2.1 to install,
and now I have the same issue with cacti-1.2.2. Tried Firefox, tried IE - get same error.

Yes, javascript is enabled on both of the browsers. I am using RedHat 6.10, php 5.6, maraia 10.2 db.
I get this dialog when I try to start the install by clicking the "Begin" button at bottom left of web browser window:
cacti-1.2.2_web_page_error.JPG
cacti-1.2.2_web_page_error.JPG (20.92 KiB) Viewed 1659 times
As always, open to suggestions

eholz1
Last edited by eholz1 on Wed May 08, 2019 6:33 pm, edited 1 time in total.

netniV
Cacti Guru User
Posts: 2808
Joined: Sun Aug 27, 2017 12:05 am

Re: First Step of cacti-1.2.2 install fails

#2 Post by netniV » Thu Mar 21, 2019 5:08 pm

You are likely experiencing some runtime errors. Either check the webserver error logs or use the web browser development tools and check the response data coming back from the JSON calls (anything not JSON is wrong!)

eholz1
Cacti User
Posts: 129
Joined: Mon Oct 01, 2018 10:09 am

Re: First Step of cacti-1.2.2 install fails

#3 Post by eholz1 » Mon Mar 25, 2019 11:51 am

These are the errors in the apache error log, not sure how to debug the web page for
json calls.

[Mon Mar 25 09:39:29.746213 2019] [:error] [pid 6421] [client 10.48.21.201:53155] PHP Notice: Undefined index: name in /opt/rh/httpd24/root/var/www/cacti-1.2.2/lib/installer.php on line 959, referer: http://10.48.11.66/cacti/install/install.php
[Mon Mar 25 09:39:30.672949 2019] [:error] [pid 6421] [client 10.48.21.201:53155] PHP Warning: Invalid argument supplied for foreach() in /opt/rh/httpd24/root/var/www/cacti-1.2.2/lib/utility.php on line 1385, referer: http://10.48.11.66/cacti/install/install.php
[Mon Mar 25 09:39:30.673368 2019] [:error] [pid 6421] [client 10.48.21.201:53155] PHP Warning: Invalid argument supplied for foreach() in /opt/rh/httpd24/root/var/www/cacti-1.2.2/lib/installer.php on line 1643, referer: http://10.48.11.66/cacti/install/install.php

I have looked in the php files here but cannot really see what is missing.

Any ideas?

Thanks,
eholz1

netniV
Cacti Guru User
Posts: 2808
Joined: Sun Aug 27, 2017 12:05 am

Re: First Step of cacti-1.2.2 install fails

#4 Post by netniV » Tue Mar 26, 2019 6:44 pm

Yeah, that's fixed in 1.2.3. It's annoying but it's should be trying to tell you about a module problem.

eholz1
Cacti User
Posts: 129
Joined: Mon Oct 01, 2018 10:09 am

Re: First Step of cacti-1.2.2 install fails

#5 Post by eholz1 » Thu Mar 28, 2019 10:24 am

Thanks again, at least you, as cacti expert, know what the message means!!
Three cheers.

I will look for cacti-1.2.3,

Thanks again,

eholz1


eholz1
Cacti User
Posts: 129
Joined: Mon Oct 01, 2018 10:09 am

Re: First Step of cacti-1.2.2 install fails

#7 Post by eholz1 » Thu Apr 04, 2019 12:12 pm

Hello Mr. Expert,
I will check this asap, thanks,

eholz1

FrSemco
Posts: 5
Joined: Mon Oct 09, 2017 6:40 am

Re: First Step of cacti-1.2.2 install fails

#8 Post by FrSemco » Tue Apr 30, 2019 5:09 am

Hi all, is it resolved for you ?
I searched and found something that resolved my 1.2.3 installation (Javascript... ERROR 200 OK ...)

On Linux Server [For me it's a Synology]


find . -name httpd
...results...
cd [...]/log/httpd
ls -lisa
find last log file
tail -f apache22-error_log

start install of cacti web (update for me 1.1.38 -> 1.2.3)
...[error]... FastCGI: server ... stderr: PHP message: PHP Warning: file_exists(): ... File(/.../sendmail) is not within the allowed path(s): ...

Seems :
Even if you don't use 'sendmail', the parameter send an error in a working version of cacti.
Go to parameters / mail / sendmail if you save, you get an error.

I have resolved this error and my install works just after.

netniV
Cacti Guru User
Posts: 2808
Joined: Sun Aug 27, 2017 12:05 am

Re: First Step of cacti-1.2.2 install fails

#9 Post by netniV » Tue Apr 30, 2019 6:22 am

Sound like we need to use the error suppression feature to make it @file_exists instead

eholz1
Cacti User
Posts: 129
Joined: Mon Oct 01, 2018 10:09 am

Re: First Step of cacti-1.2.2 install fails

#10 Post by eholz1 » Tue Apr 30, 2019 9:31 am

Interesting post - possible fix?
Sorry to be dense, How exactly was this issue resolved?

Thanks,

Eholz1

netniV
Cacti Guru User
Posts: 2808
Joined: Sun Aug 27, 2017 12:05 am

Re: First Step of cacti-1.2.2 install fails

#11 Post by netniV » Thu May 02, 2019 8:53 am

If someone can open an issue on github for the restricted paths (eg, not in allowed paths) error, that would also be good.

FrSemco
Posts: 5
Joined: Mon Oct 09, 2017 6:40 am

Re: First Step of cacti-1.2.2 install fails

#12 Post by FrSemco » Mon May 06, 2019 1:35 am

Hi , sorry for this late reply (and for my english ;) )
When I started the 1.2.3 installation, I had the javascript error, but in the logs, the error is not linked to the javascript but to 'sendmail'.

I go back to my 1.1.38 folder (working well)
I open the parameters of cacti - Mail/Reporting/DNS : I was set to 'PHP mail' but when I save, I had an error about 'sendmail' which is not found in the path.
I go to 'Sendmail' in the list and saw that the folder in my system wasn't existing:
"This is the path to sendmail on your server. (Only used if Sendmail is selected as the Mail Service)"
Even if I remove the information to blank field, I got the error.

The only way I found is to create a folder and install 'sendmail' : save was good, and the 1.2.3 installation worked after this.

Fr.

eholz1
Cacti User
Posts: 129
Joined: Mon Oct 01, 2018 10:09 am

Re: First Step of cacti-1.2.2 install fails

#13 Post by eholz1 » Tue May 07, 2019 9:01 am

Hello Fr.
your post is very interesting. I will
install sendmail on my machine, and check results.
Thanks,
eholz1

eholz1
Cacti User
Posts: 129
Joined: Mon Oct 01, 2018 10:09 am

Re: First Step of cacti-1.2.2 install fails

#14 Post by eholz1 » Wed May 08, 2019 6:32 pm

Hello FR,

Thanks for your find on the Cacti 1.2.3 install. I installed sendmail, and it works!

Thanks for this post and reply!
:D :D :D

FrSemco
Posts: 5
Joined: Mon Oct 09, 2017 6:40 am

Re: [SOLVED]First Step of cacti-1.2.2 install fails

#15 Post by FrSemco » Wed May 15, 2019 8:44 am

GOOD !! :lol:

Post Reply