Cannot disable RRA rule

Post general support questions here that do not specifically fall into the Linux or Windows categories.

Moderators: Moderators, Developers

Post Reply
Author
Message
cheratocono
Posts: 2
Joined: Sun May 26, 2019 11:55 am

Cannot disable RRA rule

#1 Post by cheratocono » Sun May 26, 2019 3:31 pm

Since I have to benchmark an algorithm I have installed cacti to monitor one machine. I wanted to disable the default RRA since I need all the raw data, so I tried to set up a Data Profile that does not make any round robin for one year:

Image

I saved the profile and I set all the data sources to match it in Template > Data Sources > Select All > Action = Change Profile > Go.

I also set up the cron job to run every 30 seconds and I updated the main settings to match the poll interval. Everything seemed to work. The problem is that if I access to data that is older that about 12 hours, I only have samples that are taken every 15 minutes instead of every 30 seconds! I noticed this when I tried to go backward in time in the Graphs tab I get the following.

Last 6 hours:
Image

<< 6 hours:
Image

<< 6 hours:
Image

<< 6 hours [now I have 15 minutes samples]
Image


Thanks to anyone can help me.

tertius
Cacti User
Posts: 72
Joined: Wed Mar 01, 2017 2:34 pm

Re: Cannot disable RRA rule

#2 Post by tertius » Sun May 26, 2019 8:55 pm

You have to delete existing *.rra files for these data sources and let Cacti create new *.rra files with the specification from the new profile. Cacti isn't able to change the properties of existing *.rra.

cheratocono
Posts: 2
Joined: Sun May 26, 2019 11:55 am

Re: Cannot disable RRA rule

#3 Post by cheratocono » Tue May 28, 2019 2:56 am

tertius wrote:You have to delete existing *.rra files for these data sources and let Cacti create new *.rra files with the specification from the new profile. Cacti isn't able to change the properties of existing *.rra.
Really thank you! :wink: Now all the data is preserved.

Post Reply