Issues with WMI plugin

Addons for Cacti and discussion about those addons

Moderators: Moderators, Developers

Post Reply
Author
Message
User avatar
Elix
Posts: 6
Joined: Thu Jul 18, 2019 10:23 am

Issues with WMI plugin

#1 Post by Elix » Thu Jul 18, 2019 10:43 am

Dears,

I've installed the latest version of the WMI plugin in Cacti 1.2.4 and today again after upgrading to 1.2.5. Two issues: It's not possible to delete saved WMI queries and it's not possible to delete stored credentials. In both cases, the confirmation popup appears but upon confirmation button, nothing happens. I can find some according entries in clog.

Attempt to delete a query:
2019/07/18 17:20:36 - CMDPHP PHP ERROR Backtrace: (/plugins/wmi/wmi_queries.php[97]:actions_queries(), /plugins/wmi/wmi_queries.php[147]:each(), CactiErrorHandler())
2019/07/18 17:20:36 - ERROR PHP DEPRECATED in Plugin 'wmi': The each() function is deprecated. This message will be suppressed on further calls in file: /xxxxxxxxxx/plugins/wmi/wmi_queries.php on line: 147
Attempt to delete credentials:
2019/07/18 17:24:55 - CMDPHP PHP ERROR Backtrace: (/plugins/wmi/wmi_accounts.php[76]:actions_accounts(), /plugins/wmi/wmi_accounts.php[122]:each(), CactiErrorHandler())
2019/07/18 17:24:55 - ERROR PHP DEPRECATED in Plugin 'wmi': The each() function is deprecated. This message will be suppressed on further calls in file: /data/apache2_wwwroot/plugins/wmi/wmi_accounts.php on line: 122
2019/07/18 17:24:47 - CMDPHP SQL Backtrace: (/plugins/wmi/wmi_accounts.php[90]:show_accounts(), /plugins/wmi/wmi_accounts.php[379]:db_fetch_cell_prepared(), /lib/database.php[378]:db_execute_prepared())
2019/07/18 17:24:47 - CMDPHP ERROR: A DB Cell Failed!, Error: Unknown column 'wmi_account' in 'field list'
  • - DB: 5.7.26-0ubuntu0.18.04.1
    - PHP: 7.2.19-0ubuntu0.18.04.1

Appreciate any help on this!

BR,
Elix

netniV
Cacti Guru User
Posts: 2673
Joined: Sun Aug 27, 2017 12:05 am

Re: Issues with WMI plugin

#2 Post by netniV » Thu Jul 18, 2019 4:14 pm

That needs reporting on the plugins repo as it's a PHP 7.2 issue (likely the plugin hasn't been through a compatibility check for the newer version).

User avatar
Elix
Posts: 6
Joined: Thu Jul 18, 2019 10:23 am

Re: Issues with WMI plugin

#3 Post by Elix » Fri Jul 19, 2019 9:20 am

Issue reported on plugin's repo now.

User avatar
Elix
Posts: 6
Joined: Thu Jul 18, 2019 10:23 am

Re: Issues with WMI plugin

#4 Post by Elix » Tue Jul 23, 2019 2:55 am

This issue has been solved by netniV and cigamit.

Thank you!

BR,
Elix

Post Reply