RouterConfigs Plugin

General discussion about Plugins for Cacti

Moderators: Moderators, Developers

Author
Message
cammpt
Posts: 12
Joined: Thu Aug 22, 2019 5:28 am

Re: RouterConfigs Plugin

#16 Post by cammpt » Mon Sep 09, 2019 1:45 am

Hi ,

I have updated and have log:

[[email protected] classes]# php /usr/share/cacti/plugins/routerconfigs/router-download.php --debug
2019/09/09 13:51:42 - RCONFIG NOTICE: Starting automatic backup
2019/09/09 13:51:42 - RCONFIG STATS: Backup now running since 2019-09-09 13:51:42
2019/09/09 13:51:42 - RCONFIG DEBUG: SQL: SELECT * FROM plugin_routerconfigs_devices WHERE enabled = 'on' AND (nextbackup <= 1568011902 OR nextbackup IS NULL)
2019/09/09 13:51:42 - RCONFIG DEBUG: Attempting download for vndc-hp5510-MacSec-1a
2019/09/09 13:51:42 - RCONFIG DEBUG: Base64 decoded: a:3:{i:602259083;i:1282015525;s:8:"password";s:9:"(9: chars)";i:834445044;i:3653736;}
2019/09/09 13:51:42 - RCONFIG DEBUG: Base64 decoded:
2019/09/09 13:51:42 - RCONFIG 10.19.207.244 -> DEBUG: both has 'PHPSsh', 'PHPTelnet'
2019/09/09 13:51:42 - RCONFIG 10.19.207.244 -> DEBUG: Attempting to use 'PHPSsh'
2019/09/09 13:51:42 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: Creating SSH Server: 10.19.207.244, User: administrator, Password: (9 chars), Enablepw: (Not Set)
2019/09/09 13:51:42 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: deviceType: {"promptuser":"username:","promptpass":"password:","copytftp":"copy start tftp","version":"show version","sleep":"125000","timeout":"1","forceconfirm":"","connecttype":"both","checkendinconfig":"on"}
2019/09/09 13:51:42 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: Setting timeout to 5 second(s)
2019/09/09 13:51:42 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: Setting sleep time to 125000 microsecond(s)
2019/09/09 13:51:43 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: okay: logged in...
2019/09/09 13:51:43 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: Connected via SSH
2019/09/09 13:51:43 - RCONFIG 10.19.207.244 (SSH) -> NOTICE: Ensuring process is enabled
2019/09/09 13:51:43 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: -->
2019/09/09 13:51:43 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <--
2019/09/09 13:51:43 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <--
2019/09/09 13:51:44 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <--
2019/09/09 13:51:44 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <--
2019/09/09 13:51:44 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <-- ******************************************************************************
2019/09/09 13:51:44 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <--
2019/09/09 13:51:44 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <-- * Copyright (c) 2010-2018 Hewlett Packard Enterprise Development LP *
2019/09/09 13:51:44 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <--
2019/09/09 13:51:44 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <-- * Without the owner's prior written consent, *
2019/09/09 13:51:44 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <--
2019/09/09 13:51:44 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <-- * no decompiling or reverse-engineering shall be allowed. *
2019/09/09 13:51:44 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <--
2019/09/09 13:51:44 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <-- ******************************************************************************
2019/09/09 13:51:44 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <--
2019/09/09 13:51:44 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <--
2019/09/09 13:51:44 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <--
2019/09/09 13:51:44 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <--
2019/09/09 13:51:45 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <-- <vndc-hp5510-MacSec-1a>
2019/09/09 13:51:45 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: Found Prompt (Normal)
2019/09/09 13:51:45 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: Attempt 1 of 10 to find prompt
2019/09/09 13:51:45 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: No enable command set, unable to elevate
2019/09/09 13:51:45 - RCONFIG 10.19.207.244 (SSH) -> Process is now NOT enabled
2019/09/09 13:51:45 - RCONFIG ERROR: Failed to download 'vndc-hp5510-MacSec-1a' to '/tftpdata/vndc-hp5510-MacSec-1a' via 'both'
2019/09/09 13:51:45 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: --> exit
2019/09/09 13:51:45 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <--
2019/09/09 13:51:45 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <--
2019/09/09 13:51:45 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <-- <vndc-hp5510-MacSec-1a>exit
2019/09/09 13:51:45 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: <--
2019/09/09 13:51:50 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: Timeout of 5 seconds has been reached
2019/09/09 13:51:50 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: Checking for valid incoming file at /tftpdata/vndc-hp5510-MacSec-1a
2019/09/09 13:51:50 - RCONFIG 10.19.207.244 (SSH) -> ERROR: Failed to find file at /tftpdata/vndc-hp5510-MacSec-1a
2019/09/09 13:51:50 - RCONFIG NOTICE: Failed to download for vndc-hp5510-MacSec-1a
2019/09/09 13:51:50 - RCONFIG WARNING: 0 Devices Backed Up, 1 Devices Failed, 1 Disabled (ignored) in 8 seconds
2019/09/09 13:51:50 - RCONFIG DEBUG: 0 devices backed up successfully.
2019/09/09 13:51:50 - RCONFIG DEBUG: 1 devices failed to backup.
2019/09/09 13:51:50 - RCONFIG DEBUG: 1 devices disabled from backup.
2019/09/09 13:51:50 - RCONFIG STATS: Time:7.88 Downloaded:0 Failed:1



I Only see the different line:
2019/09/09 13:51:45 - RCONFIG 10.19.207.244 (SSH) -> DEBUG: No enable command set, unable to elevate

Please help !

netniV
Cacti Guru User
Posts: 2796
Joined: Sun Aug 27, 2017 12:05 am

Re: RouterConfigs Plugin

#17 Post by netniV » Wed Sep 11, 2019 4:30 am

That's OK, that's the line I wanted to see to verify that my thoughts on this were correct.

cammpt
Posts: 12
Joined: Thu Aug 22, 2019 5:28 am

Re: RouterConfigs Plugin

#18 Post by cammpt » Wed Sep 11, 2019 4:46 am

netniV wrote:
Wed Sep 11, 2019 4:30 am
That's OK, that's the line I wanted to see to verify that my thoughts on this were correct.
Cool ! could you fix it? On HP Comware don't have enable mode, when I login on the HP Device i can run the backup command

thx!

cammpt
Posts: 12
Joined: Thu Aug 22, 2019 5:28 am

Re: RouterConfigs Plugin

#19 Post by cammpt » Tue Sep 17, 2019 10:55 pm

hi NetniV,

Do you have any update?


cammpt
Posts: 12
Joined: Thu Aug 22, 2019 5:28 am

Re: RouterConfigs Plugin

#21 Post by cammpt » Wed Sep 18, 2019 4:39 am

netniV wrote:
Wed Sep 18, 2019 2:20 am
It's not done yet.
Thx for your information, i'm waiting for you.

Post Reply