Stalker CommuniGate Pro addon

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Author
Message
paddy
Posts: 14
Joined: Thu Jul 15, 2004 9:34 am
Location: Stockholm, Sweden

Stalker CommuniGate Pro addon

#1 Post by paddy » Mon Aug 02, 2004 9:54 am

I've never done this before but here it goes anyways.

This is a addon that will add graphs from a CommuniGate pro server running SNMP. It will graph varius things that the CG server outputs via SNMP.

This is for Cacti 0.8.5a.

As I said I've never posted a addon here before so add it on your own risk!
It might kill your server burn down your house yaddayadda...

Known bugs:
1. Cant get rith of the annoying MmGk and so on from the graphs and legend.
Attachments
cacti_host_template_communigate_server.xml
CommuniGate pro addon
(116.01 KiB) Downloaded 1941 times

rmcclain

#2 Post by rmcclain » Tue Sep 14, 2004 6:45 pm

I downloaded your xml file, but when i attempt to import it, I get an XML parse error. Perhaps it's because I'm running 0.8.6. If you have a template that works for 0.8.6, could you upload it? Or if anyone has worked on integrating cacti with communigate, I'd like to hear what you've got and how it's working out.

-Ron

paddy
Posts: 14
Joined: Thu Jul 15, 2004 9:34 am
Location: Stockholm, Sweden

#3 Post by paddy » Wed Sep 15, 2004 2:58 am

Well, dunno if it helps.. but this works in my 0.8.6. Ofcourse I had it in there during the upgrade.. so perhaps it corrected something on the way..
Attachments
cacti_host_template_communigate_server.xml
Works on my Cacti 0.8.6 ..
(116.01 KiB) Downloaded 1459 times

rmcclain

#4 Post by rmcclain » Wed Sep 15, 2004 4:05 pm

The file still wouldn't import, but I tracked it down. Replace all occurances of
IMAP & POP
with
IMAP and POP
and it works.

rmcclain

#5 Post by rmcclain » Wed Sep 15, 2004 4:07 pm

One other thing. Do you have a copy of the <path_cacti>/resource/snmp_queries/communigate.xml file?

Thanks for posting this. This will save me a lot of work.
-Ron

paddy
Posts: 14
Joined: Thu Jul 15, 2004 9:34 am
Location: Stockholm, Sweden

#6 Post by paddy » Wed Sep 15, 2004 6:07 pm

There is no surch file..
never been one ether so.. sorry :/

- sorry for the spelling.. been up half the nite moving our CommuniGate from one HW to another.. phew..

mgeni
Cacti User
Posts: 65
Joined: Fri Mar 25, 2005 8:12 am

#7 Post by mgeni » Tue May 24, 2005 10:20 am

I am getting the same error

Error: XML parse error.

My version 0.8.6c

Has anyone been successful.

sbudach
Posts: 2
Joined: Sun Mar 13, 2005 1:27 am

#8 Post by sbudach » Fri Jun 03, 2005 10:49 am

Hi all,

I encountered no problems importing and using the template despite the fact, tha I had to change the "POP & IMAP" to "POP and IMAP".

I admit that the rulers on some graphs are a bit annoying, though. But the graph templates worked out of the box.

My cacti is 0.8.6c.

Cheers,
Stephan

Farmer
Posts: 20
Joined: Sat Feb 22, 2003 4:17 pm
Location: Kazakhstan

#9 Post by Farmer » Sat Jun 04, 2005 4:31 pm

sbudach wrote:Hi all,

I encountered no problems importing and using the template despite the fact, tha I had to change the "POP & IMAP" to "POP and IMAP".

I admit that the rulers on some graphs are a bit annoying, though. But the graph templates worked out of the box.

My cacti is 0.8.6c.

Cheers,
Stephan
Yes, it is necessary to replace "&" for example on "and". Except for that I have found some mistakes in OIDs and Data Source Type in Data Templates. It is corrected template.
I have CommuniGate Pro Server version 4.3c3 and Cacti version 0.8.6d
Attachments
cacti_host_template_communigate_server.xml
Corrected template for CommuniGate Pro mail server
(117.51 KiB) Downloaded 1662 times
Cheers,
Andrey

sbudach
Posts: 2
Joined: Sun Mar 13, 2005 1:27 am

#10 Post by sbudach » Sun Jun 05, 2005 2:13 am

Hi,

when I try to import your new template I get a

Error: XML: Hash version does not exist.

Any ideas?

Thanks,
Stephan

mgeni
Cacti User
Posts: 65
Joined: Fri Mar 25, 2005 8:12 am

#11 Post by mgeni » Mon Jun 06, 2005 8:23 am

I also get the same error. I use Version 0.8.6c. I would love to hear suggestions on this.

3ngin33r1
Posts: 11
Joined: Mon Jun 06, 2005 4:34 pm

#12 Post by 3ngin33r1 » Mon Jun 06, 2005 4:44 pm

6c as well, same issue.

Farmer
Posts: 20
Joined: Sat Feb 22, 2003 4:17 pm
Location: Kazakhstan

#13 Post by Farmer » Tue Jun 07, 2005 11:17 am

sbudach wrote:Hi,

when I try to import your new template I get a

Error: XML: Hash version does not exist.

Any ideas?

Thanks,
Stephan
I am sorry, it is my first attempt of export template, and I unfortunately cannot understand in what a problem. Now I shall try to restore base from a backup copy and to import template.
Cheers,
Andrey

Farmer
Posts: 20
Joined: Sat Feb 22, 2003 4:17 pm
Location: Kazakhstan

#14 Post by Farmer » Tue Jun 07, 2005 12:28 pm

sbudach wrote:Hi,

when I try to import your new template I get a

Error: XML: Hash version does not exist.

Any ideas?

Thanks,
Stephan
I seem has understood.
Error: XML: Hash version does not exist
there can be in the event that your version cacti more less, than that from which has been made export (if I have correctly understood function check_hash_version ($hash_version) - I almost do not know php).
Cheers,
Andrey

3ngin33r1
Posts: 11
Joined: Mon Jun 06, 2005 4:34 pm

#15 Post by 3ngin33r1 » Tue Jun 07, 2005 5:59 pm

Ok, so after a lot of copying work, I got this working on 0.8.6c and exported the template.

If this doesn't work for you, please don't expect any help, I'm probably newer at this than you are...
Attachments
cacti_host_template_communigate_server086c.xml
CGP Template exported with 0.8.6c
(118.95 KiB) Downloaded 2698 times

Post Reply