TeamSpeak - Current Players

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Author
Message
Pinky
Posts: 15
Joined: Sat May 07, 2005 3:00 pm
Location: Germany - Munich

TeamSpeak - Current Players

#1 Post by Pinky » Sat May 07, 2005 3:10 pm

This plugin shows the current number of players, who are connected on your local TeamSpeakServer.

INSTALL:

1.copy the ts.php into your scripts directory
2. import the xml file using the cacti webinterface

UPDATE:

11.05.05 - I fixed the average bug
Attachments
teamspeak_cacti.zip
(2.33 KiB) Downloaded 2231 times
Last edited by Pinky on Wed May 11, 2005 10:14 am, edited 2 times in total.

Pinky
Posts: 15
Joined: Sat May 07, 2005 3:00 pm
Location: Germany - Munich

Picture

#2 Post by Pinky » Sat May 07, 2005 3:28 pm

Picture:
Attachments
graph_image.php.png
graph_image.php.png (21.41 KiB) Viewed 29491 times
Last edited by Pinky on Tue Jun 21, 2005 8:46 am, edited 1 time in total.

FireMail
Posts: 10
Joined: Sun May 08, 2005 7:32 am
Contact:

#3 Post by FireMail » Tue May 10, 2005 6:43 am

thanks dude! works great :D

mindstormmaster
Posts: 6
Joined: Sat Mar 12, 2005 11:14 pm

#4 Post by mindstormmaster » Tue Jun 14, 2005 3:00 pm

What version of cacti was this created with? I'm running 0.8.6d and it tells me the template was created with a newer version.

cdegroat
Cacti User
Posts: 52
Joined: Thu Jun 16, 2005 5:56 pm

#5 Post by cdegroat » Fri Jun 17, 2005 11:49 am

when i try and download i get a download.php file. I dont get the zip... =(

Pinky
Posts: 15
Joined: Sat May 07, 2005 3:00 pm
Location: Germany - Munich

#6 Post by Pinky » Fri Jun 17, 2005 4:40 pm

I'm using 0.8.6d, too.

Download should work. If not, ask the administrator

mindstormmaster
Posts: 6
Joined: Sat Mar 12, 2005 11:14 pm

#7 Post by mindstormmaster » Sat Jun 18, 2005 12:55 am

I found my problem. I'm using Gentoo Linux. I upgraded cacti using the emerge command, but it failed to completely update cacti. Specifically it didn't change the version label in the config.php file.

cdegroat
Cacti User
Posts: 52
Joined: Thu Jun 16, 2005 5:56 pm

#8 Post by cdegroat » Sun Jun 19, 2005 10:52 pm

Ok cleared up all TS importing issues by upgrading. Now i have a TS graph, but everything is labeled nan for any outputs. Graph is blank. Any ideas? Thanks in advance!

Pinky
Posts: 15
Joined: Sat May 07, 2005 3:00 pm
Location: Germany - Munich

#9 Post by Pinky » Mon Jun 20, 2005 3:56 am

post your "php $cactidir/scripts/ts.php" output

cdegroat
Cacti User
Posts: 52
Joined: Thu Jun 16, 2005 5:56 pm

#10 Post by cdegroat » Mon Jun 20, 2005 9:16 am

@www cacti]# /www/php/bin/php poller.php
06/20/2005 10:17:17 AM - POLLER: Poller[0] DEBUG: About to Spawn a Remote Process [CMD: /usr/bin/php, ARGS: -q /www/htdocs/cacti/cmd.php 0 1]
Waiting on 1/1 pollers.
Waiting on 1/1 pollers.
06/20/2005 10:17:18 AM - POLLER: Poller[0] Parsed MULTI output field '1min:1.80' [map 1min->load_1min]
06/20/2005 10:17:18 AM - POLLER: Poller[0] Parsed MULTI output field '5min:1.61' [map 5min->load_5min]
06/20/2005 10:17:18 AM - POLLER: Poller[0] Parsed MULTI output field '10min:1.30' [map 10min->load_15min]
06/20/2005 10:17:18 AM - POLLER: Poller[0] CACTI2RRD: /usr/local/rrdtool/bin/rrdtool update /www/htdocs/cacti/rra/localhost_mem_buffers_3.rrd --template mem_buffers 1119280637:14208
OK u:0.00 s:0.00 r:1.02
06/20/2005 10:17:18 AM - POLLER: Poller[0] CACTI2RRD: /usr/local/rrdtool/bin/rrdtool update /www/htdocs/cacti/rra/localhost_mem_swap_4.rrd --template mem_swap 1119280637:2096264
OK u:0.00 s:0.00 r:1.02
06/20/2005 10:17:18 AM - POLLER: Poller[0] CACTI2RRD: /usr/local/rrdtool/bin/rrdtool update /www/htdocs/cacti/rra/localhost_load_1min_5.rrd --template load_1min:load_5min:load_15min 1119280637:1.80:1.61:1.30
OK u:0.00 s:0.00 r:1.03
06/20/2005 10:17:18 AM - POLLER: Poller[0] CACTI2RRD: /usr/local/rrdtool/bin/rrdtool update /www/htdocs/cacti/rra/localhost_users_6.rrd --template users 1119280637:1
OK u:0.00 s:0.00 r:1.03
06/20/2005 10:17:18 AM - POLLER: Poller[0] CACTI2RRD: /usr/local/rrdtool/bin/rrdtool update /www/htdocs/cacti/rra/localhost_proc_7.rrd --template proc 1119280637:91
OK u:0.00 s:0.00 r:1.03
Waiting on 1/1 pollers.
Waiting on 1/1 pollers.
Waiting on 1/1 pollers.
Timeout: No Response from 127.0.0.1:161.
Waiting on 1/1 pollers.
06/20/2005 10:17:22 AM - POLLER: Poller[0] CACTI2RRD: /usr/local/rrdtool/bin/rrdtool update /www/htdocs/cacti/rra/localhost_cpu_nice_8.rrd --template cpu_nice 1119280637:U
OK u:0.00 s:0.00 r:5.04
Waiting on 1/1 pollers.
Waiting on 1/1 pollers.
Waiting on 1/1 pollers.
Timeout: No Response from 127.0.0.1:161.
Waiting on 1/1 pollers.
06/20/2005 10:17:26 AM - POLLER: Poller[0] CACTI2RRD: /usr/local/rrdtool/bin/rrdtool update /www/htdocs/cacti/rra/localhost_cpu_system_9.rrd --template cpu_system 1119280637:U
OK u:0.00 s:0.00 r:9.06
Waiting on 1/1 pollers.
Waiting on 1/1 pollers.
Waiting on 1/1 pollers.
Timeout: No Response from 127.0.0.1:161.
06/20/2005 10:17:30 AM - POLLER: Poller[0] CACTI2RRD: /usr/local/rrdtool/bin/rrdtool update /www/htdocs/cacti/rra/localhost_online_12.rrd --template online 1119280637:U
06/20/2005 10:17:30 AM - POLLER: Poller[0] CACTI2RRD: /usr/local/rrdtool/bin/rrdtool update /www/htdocs/cacti/rra/localhost_hdd_free_11.rrd --template hdd_free:hdd_used 1119280637:55407452:15549676
06/20/2005 10:17:30 AM - POLLER: Poller[0] CACTI2RRD: /usr/local/rrdtool/bin/rrdtool update /www/htdocs/cacti/rra/localhost_cpu_user_10.rrd --template cpu_user 1119280637:U
OK u:0.00 s:0.00 r:13.08
OK u:0.00 s:0.00 r:13.08
06/20/2005 10:17:30 AM - SYSTEM STATS: Time: 13.1218 s, Method: cmd.php, Processes: 1, Threads: N/A, Hosts: 2, Hosts/Process: 2
OK u:0.00 s:0.00 r:13.08
06/20/2005 10:17:30 AM - EXPORT: Poller[0] Running graph export
391x153
OK u:0.01 s:0.00 r:0.07
591x218
OK u:0.03 s:0.00 r:0.14
591x218
OK u:0.05 s:0.01 r:0.19
591x218
OK u:0.06 s:0.01 r:0.24
591x218
OK u:0.08 s:0.01 r:0.30
391x153
OK u:0.09 s:0.01 r:0.33
591x231
OK u:0.11 s:0.01 r:0.42
591x231
OK u:0.13 s:0.01 r:0.50
591x231
OK u:0.15 s:0.02 r:0.55
591x231
OK u:0.17 s:0.02 r:0.57
391x153
OK u:0.18 s:0.02 r:0.58
591x192
OK u:0.19 s:0.02 r:0.59
591x192
OK u:0.21 s:0.02 r:0.61
591x192
OK u:0.22 s:0.02 r:0.63
591x192
OK u:0.24 s:0.02 r:0.64
391x153
OK u:0.25 s:0.02 r:0.65
591x205
OK u:0.26 s:0.02 r:0.67
591x205
OK u:0.28 s:0.02 r:0.69
591x205
OK u:0.30 s:0.02 r:0.71
591x205
OK u:0.31 s:0.03 r:0.72
391x153
OK u:0.32 s:0.03 r:0.73
591x192
OK u:0.34 s:0.03 r:0.76
591x192
OK u:0.35 s:0.03 r:0.78
591x192
OK u:0.37 s:0.03 r:0.81
591x192
OK u:0.38 s:0.03 r:0.85
391x153
OK u:0.39 s:0.03 r:0.87
591x192
OK u:0.41 s:0.03 r:0.90
591x192
OK u:0.42 s:0.03 r:0.94
591x192
OK u:0.44 s:0.03 r:0.96
591x192
OK u:0.46 s:0.03 r:0.98
[[email protected] cacti]#

Pinky
Posts: 15
Joined: Sat May 07, 2005 3:00 pm
Location: Germany - Munich

#11 Post by Pinky » Mon Jun 20, 2005 1:03 pm

Sorry, but you've posted the wrong log. Post your "php cacti/scripts/ts.php" output.

Here's my output:

Code: Select all

server scripts # php ts.php
1server scripts #

cdegroat
Cacti User
Posts: 52
Joined: Thu Jun 16, 2005 5:56 pm

#12 Post by cdegroat » Mon Jun 20, 2005 1:11 pm

[[email protected] scripts]# /www/php/bin/php ts.php
3[[email protected] scripts]#


Sorry about the confusion. Seems its checking that 3 users are on?

Pinky
Posts: 15
Joined: Sat May 07, 2005 3:00 pm
Location: Germany - Munich

#13 Post by Pinky » Tue Jun 21, 2005 6:29 am

Sounds good ! Perhaps you've to update you Cacti.

cdegroat
Cacti User
Posts: 52
Joined: Thu Jun 16, 2005 5:56 pm

#14 Post by cdegroat » Tue Jun 21, 2005 9:26 am

I was using version d. I guess ill go with version e and see what happens!

cdegroat
Cacti User
Posts: 52
Joined: Thu Jun 16, 2005 5:56 pm

#15 Post by cdegroat » Tue Jun 21, 2005 10:18 am

I just upgraded to version e. More like i did a fresh install just to make sure. I still get nothing on the team speak graph.

Post Reply