SNMP4NT

Post support questions that relate to the Windows 2003/2000/XP operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
User avatar
AndyStewart
Cacti User
Posts: 102
Joined: Thu Sep 29, 2005 5:21 am
Location: Edinburgh, Scotland

SNMP4NT

#1 Post by AndyStewart » Tue Apr 11, 2006 4:51 am

Still have a couple of old NT4 servers (legacy applications), and have CACTI monitoring them using SNMP4NT to get memory info.

Unfortunately, i don't know if there's a 2GB limit on what it can report for memory usage - box has 2GB Physical memory installed in it, but my graphs seem to be flatlined showing 114.3 MB memory used, when its actually using 1485 MB...

any ideas?

Example graph below, and screenshot of task manager from NT server showing mem usage
Attachments
awdlive1.jpg
awdlive1.jpg (35.52 KiB) Viewed 5096 times
awdlive2.jpg
awdlive2.jpg (69.75 KiB) Viewed 5096 times
I don't care if the glass is half full or half empty, i want to know, who's been drinking my pint!!!

[size=75][Windows 2003 & IIS6] [Cacti 0.8.7b] [ActivePerl 5.8.8.817] [MySql 5.0.19] [NetSNMP 5.2.1.2-1] [PHP 5.1.2] [RRDTool 1.2.11]
[Plugins: PluginArchitecture, Monitor, Discovery, Threshold, Update, Reports, Manage, RealTime][/size]

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

#2 Post by BSOD2600 » Tue Apr 11, 2006 12:22 pm

Either run a cacti polling cycle with the logging level set to HIGH or SNMPGET the OID for the memory usage. What does either report back?

You might need to create a simple CDEF which makes the scale number correct.

georger_br
Cacti User
Posts: 63
Joined: Mon Jul 04, 2005 10:12 am
Location: Brazil

Re: SNMP4NT

#3 Post by georger_br » Wed May 03, 2006 11:27 am

It's a bug in the template. I just updated it - get it at http://forums.cacti.net/viewtopic.php?t=8579
Regards,

Georger

User avatar
AndyStewart
Cacti User
Posts: 102
Joined: Thu Sep 29, 2005 5:21 am
Location: Edinburgh, Scotland

#4 Post by AndyStewart » Thu May 04, 2006 3:27 am

Am trying to import the new template (updated May 3rd), and am getting the following error:
Warning: filesize() [function.filesize]: stat failed for C:\WINDOWS\TEMP\php24F7.tmp in E:\Inetpub\wwwroot\cacti\templates_import.php on line 59

Warning: fread() [function.fread]: Length parameter must be greater than 0 in E:\Inetpub\wwwroot\cacti\templates_import.php on line 59

Warning: Cannot modify header information - headers already sent by (output started at E:\Inetpub\wwwroot\cacti\templates_import.php:59) in E:\Inetpub\wwwroot\cacti\templates_import.php on line 71
Any ideas?
I don't care if the glass is half full or half empty, i want to know, who's been drinking my pint!!!

[size=75][Windows 2003 & IIS6] [Cacti 0.8.7b] [ActivePerl 5.8.8.817] [MySql 5.0.19] [NetSNMP 5.2.1.2-1] [PHP 5.1.2] [RRDTool 1.2.11]
[Plugins: PluginArchitecture, Monitor, Discovery, Threshold, Update, Reports, Manage, RealTime][/size]

User avatar
BSOD2600
Cacti Moderator
Posts: 12160
Joined: Sat May 08, 2004 12:44 pm
Location: USA

#5 Post by BSOD2600 » Thu May 04, 2006 10:20 am

You need to change the NTFS permissions on your windows temp directory to allow the webuser account to write files.

User avatar
AndyStewart
Cacti User
Posts: 102
Joined: Thu Sep 29, 2005 5:21 am
Location: Edinburgh, Scotland

#6 Post by AndyStewart » Fri May 05, 2006 3:17 am

Bingo - thats exactly what is was BSOD...cheers again...
I don't care if the glass is half full or half empty, i want to know, who's been drinking my pint!!!

[size=75][Windows 2003 & IIS6] [Cacti 0.8.7b] [ActivePerl 5.8.8.817] [MySql 5.0.19] [NetSNMP 5.2.1.2-1] [PHP 5.1.2] [RRDTool 1.2.11]
[Plugins: PluginArchitecture, Monitor, Discovery, Threshold, Update, Reports, Manage, RealTime][/size]

Post Reply