[SOLVED] Plugins not showing within cacti

Support questions about the Threshold plugin

Moderators: Moderators, Developers

Author
Message
thierryct
Posts: 3
Joined: Sun Nov 19, 2017 3:12 am

[SOLVED] Plugins not showing within cacti

#1 Post by thierryct » Tue Nov 21, 2017 4:49 am

On Cacti 1.1.27, i installed 'thold' in its version 1.0.4 (since GitHub). However, it does not yet appear in templates (administrator profile) for a first test of use. Is there anything special to do once the plugin is installed?

thierryct
Posts: 3
Joined: Sun Nov 19, 2017 3:12 am

Re: 'Thold' does not appear in templates

#2 Post by thierryct » Wed Nov 22, 2017 10:12 am

There is nobody to help me to show the features of this plugin ?

netniV
Cacti Guru User
Posts: 2978
Joined: Sun Aug 27, 2017 12:05 am

Re: 'Thold' does not appear in templates

#3 Post by netniV » Fri Jan 05, 2018 3:34 am

Have you enabled and installed the plugin? There are two steps to take.

Under Configuration-> Plugin Management, on the row where the plugin you want is, there will be a button saying "Install" (or Uninstall if already installed). Next to that will be a button that says "Enable" (or Disable if you have already enabled). The idea is, you can change any system wide settings in the Configuration -> Settings that apply to that plugin before enabling it.

Finally, one other thing worthy of mentioning is that cacti will automatically disable a plugin if there are any unexpected errors. So, even if you already enabled a plugin, if there is an immediate error, it will automatically disable the plugin again preventing the other plugin pages from appearing. Check the logs to see if that is occurring.

yllam
Posts: 2
Joined: Thu Mar 08, 2018 12:31 pm

Re: 'Thold' does not appear in templates

#4 Post by yllam » Thu Mar 08, 2018 12:43 pm

Yes, same here. The threshold wizzard configuration is missing from the Management bar (left side navigation tool). I have the Thresholds tab from the Configuration navigator bar (settings) and Plugin Management is "Active" enabled for Thold plugin. I am running Cacti 1.1.35 and Thold 1.0.4. Any information on this?

netniV
Cacti Guru User
Posts: 2978
Joined: Sun Aug 27, 2017 12:05 am

Re: 'Thold' does not appear in templates

#5 Post by netniV » Thu Mar 08, 2018 5:00 pm

Did you give access via the Realms in the user / group settings for security?

User avatar
gdsotirov
Posts: 23
Joined: Fri Sep 19, 2014 3:33 am
Location: Sofia, Bulgaraia
Contact:

Re: 'Thold' does not appear in templates

#6 Post by gdsotirov » Wed Mar 14, 2018 7:34 am

I have the same problem with Thold downloaded from GitHub and freshly upgraded Cacti 1.1.36. I have extracted the plugin into plugins/thold (the directory and files inside readable to all), but the plugin just doesn't appear in Plugin Management. What you've meant by "give access via the Realms in the user / group settings for security"?

netniV
Cacti Guru User
Posts: 2978
Joined: Sun Aug 27, 2017 12:05 am

Re: 'Thold' does not appear in templates

#7 Post by netniV » Wed Mar 14, 2018 7:41 am

Wait, you are saying that you have copied into <cacti>/plugins/thold/ but the plugin isn't showing in the list? Does the website user have access to that folder? Make sure it does as if you've downloaded/extracted as root, there may not be the correct permissions on the folders/files.

User avatar
gdsotirov
Posts: 23
Joined: Fri Sep 19, 2014 3:33 am
Location: Sofia, Bulgaraia
Contact:

Re: 'Thold' does not appear in templates

#8 Post by gdsotirov » Wed Mar 14, 2018 7:49 am

OK, but what are the necessary permissions exactly and where is this described? Currently, I have r-x on the folder pluginds/thold and the sub folders inside it as well as r-- on all the files inside these folders for all the users. I tried also changing ownership to web server user, but still nothing. Should there be an error message in the log if it's about permissions?

netniV
Cacti Guru User
Posts: 2978
Joined: Sun Aug 27, 2017 12:05 am

Re: 'Thold' does not appear in templates

#9 Post by netniV » Wed Mar 14, 2018 8:33 am

As long as the folder name fits in with the regex [A-Za-z0-9\-_] it should be OK. Permissions won't show as an error per sae, because if the website user has no access to the folders, it can't be sure it's a plugin at all.

The other thing to do, is make sure you can do

sudo -u <website user> cat <plugin folder>/INFO

If that works, the plugin should be showing up.

User avatar
gdsotirov
Posts: 23
Joined: Fri Sep 19, 2014 3:33 am
Location: Sofia, Bulgaraia
Contact:

Re: 'Thold' does not appear in templates

#10 Post by gdsotirov » Wed Mar 14, 2018 8:51 am

Folder name fits even into [a-z], as it's just "thold" as I wrote before.

And here is the executed command:

Code: Select all

# sudo -u apache cat /var/www/cacti/plugins/thold/INFO
[info]
name = thold
version = 1.0.4
longname = Thresholds
author = The Cacti Group
email =
homepage = http://www.cacti.net
compat = 1.1.4
capabilities = online_view:1, online_mgmt:1, offline_view:0, offline_mgmt:0, remote_collect:1
Again as I wrote I do not think this is a permission problem. Is there any way I could find out more information about the problem (e.g. debug) this?


User avatar
gdsotirov
Posts: 23
Joined: Fri Sep 19, 2014 3:33 am
Location: Sofia, Bulgaraia
Contact:

Re: 'Thold' does not appear in templates

#12 Post by gdsotirov » Wed Mar 14, 2018 9:08 am

Slackware Linux 14.2 with Kernel 4.4.119, Apache 2.4.29 and PHP 5.6.34 running Cacti 1.1.36 (as I already wrote). But how is this relevant to the plugin problem? More importantly how could I debug it? I tried enabling debug on plugins.php in Settings, but nothing gets printed into log/cacti.log when I open Plugins management page. Should I also increase debug level?

netniV
Cacti Guru User
Posts: 2978
Joined: Sun Aug 27, 2017 12:05 am

Re: 'Thold' does not appear in templates

#13 Post by netniV » Wed Mar 14, 2018 11:09 am

It shouldn't matter, but it gives me a basis for what your system is running so I have a better idea of what you are working with.

Does the plugins.php show anything if you go to it directly?
https://<cacti url>/plugins.php

If that is blank in the middle, you should have either an error in the HTTPD error log or the cacti.log file. Do you have anything else underneath the plugin folder? If so, try moving them out temporarily and moving them back in one at a time to see when it goes wrong.

Failing that, you'll have to start manually debugging the plugins.php file with something writing to a file so you can see where it's getting up to. I tend to use

Code: Select all

file_put_contents('/tmp/<filename>','<message>', FILE_APPEND);

User avatar
gdsotirov
Posts: 23
Joined: Fri Sep 19, 2014 3:33 am
Location: Sofia, Bulgaraia
Contact:

Re: 'Thold' does not appear in templates

#14 Post by gdsotirov » Wed Mar 14, 2018 11:59 am

Sure.

The plugins page is well displayed, but it states "No Plugins found" (see attached screenshot).

I found no errors in cacti's or httpd's log. In the plugins folder I have just index.php and the thold plugin:

Code: Select all

# ls -alh
total 16K
drwxrwxr-x  3 apache apache 4.0K Mar 14 18:56 ./
drwxr-xr-x 17 root   root   4.0K Mar 14 16:22 ../
-rw-rw-r--  1 root   root     40 Feb 26 03:12 index.php
drwxr-xr-x  8 apache apache 4.0K Mar 14 15:42 thold/
It makes me think that I've never used cacti plugins so far...

For the manual debug, I'll try it later and I'll write back.
Attachments
cacti_no_plugins_found.png
cacti_no_plugins_found.png (12.51 KiB) Viewed 1989 times


Post Reply